1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Updating Plesk 8.4 to php5.2

Discussion in 'Plesk for Linux - 8.x and Older' started by pixelhaus, Jul 21, 2008.

  1. pixelhaus

    pixelhaus Guest

    0
     
    I am currently running Plesk 8.4 on a Linux box with Ubuntu 6.06. The default version of php is 5.1.2 but we want to update this to 5.2.6 . Is there a simple upgrade path that doesn't involve compiling files etc ?
     
  2. breun

    breun Golden Pleskian

    29
     
    Joined:
    Jun 28, 2005
    Messages:
    1,647
    Likes Received:
    0
    If you don't need any PHP 5.2.x-specific features, I recommend staying with the vendor supplied packages as the Ubuntu folks probably do a better job at keeping their software patched than some random packager. If you really do need PHP 5.2's features I believe you should be able to use the third-party Dotdeb repository: http://www.dotdeb.org/
     
  3. pixelhaus

    pixelhaus Guest

    0
     
    The CMS software we are favouring at the moment has a glitch with php5.1 that is solved with 5.2 so i'll try it, thanks.
     
  4. pixelhaus

    pixelhaus Guest

    0
     
    I added the additional source but it caused conflicts. i think I'll wait for plesk to update it in the due course of time
     
  5. danliker

    danliker Silver Pleskian Plesk Certified Professional

    33
    43%
    Joined:
    Feb 15, 2006
    Messages:
    575
    Likes Received:
    0
    Location:
    Switzerland
    plesk will never update the client side php version.
    plesk use the php version from your distribution (ubuntu 6.0.6) for the client side ....
     
  6. mariusc

    mariusc Guest

    0
     
    So, after all it can be updated manually? (i'm using suse 10.0)
    I need php 5.2 for use with joomla 1.5.x
     
  7. monsefc

    monsefc Guest

    0
     
    any news about this subjet ? i need to update my php version from 5.1.6 to 5.2
     
  8. danliker

    danliker Silver Pleskian Plesk Certified Professional

    33
    43%
    Joined:
    Feb 15, 2006
    Messages:
    575
    Likes Received:
    0
    Location:
    Switzerland
    what is the problem?
    plesk does not include php, just update your OS!
     
  9. breun

    breun Golden Pleskian

    29
     
    Joined:
    Jun 28, 2005
    Messages:
    1,647
    Likes Received:
    0
    That entirely depends on whether someone has packaged PHP 5.2 for your OS distribution (what are you running?). If no one did, you'll need to do it yourself, or find someone who will do it for you.
     
Loading...