1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Upgrade 4.0 to 4.2

Discussion in 'Sitebuilder 4.0 for Linux' started by dnerty, Apr 28, 2008.

  1. dnerty

    dnerty Guest

    0
     
    CentOS5, upgrade 4.0 to 4.2 with autoinstaler.. (Tried to upgrade from 4.0 to 4.1, but the same problems appeared)


    A lot of error messages :

    (can't catch very begining) ..

    conflict with package Business_pack14-4.0.0.20070903-1.noarch
    both have file /usr/local/sitebuilder/htdocs/templates/xrot-05/info.xml with different md5 sum.
    Warning: packages conflict by files detected: package Business_pack2-4.1.0.20071205-1.noarch
    conflict with package Business_pack2-4.0.0.20070903-1.noarch
    both have file /usr/local/sitebuilder/htdocs/templates/as-07/green/buttons/buttons1/buttons.xsl with different md5 sum.
    Warning: packages conflict by files detected: package Business_pack4-4.1.0.20071205-1.noarch
    conflict with package Business_pack4-4.0.0.20070903-1.noarch
    both have file /usr/local/sitebuilder/htdocs/templates/av-256/blue/buttons/buttons1.jpg with different md5 sum.
    Warning: packages conflict by files detected: package Business_pack6-4.1.0.20071205-1.noarch
    conflict with package Business_pack6-4.0.0.20070903-1.noarch
    both have file /usr/local/sitebuilder/htdocs/templates/business-013/info.xml with different md5 sum.
    Warning: packages conflict by files detected: package Business_pack7-4.1.0.20071205-1.noarch
    conflict with package Business_pack7-4.0.0.20070903-1.noarch
    both have file /usr/local/sitebuilder/htdocs/templates/business-025/info.xml with different md5 sum.
    Warning: packages conflict by files detected: package Business_pack8-4.1.0.20071205-1.noarch
    conflict with package Business_pack8-4.0.0.20070903-1.noarch
    both have file /usr/local/sitebuilder/htdocs/templates/business-031/info.xml with different md5 sum.
    Warning: packages conflict by files detected: package Business_pack9-4.1.0.20071205-1.noarch
    conflict with package Business_pack9-4.0.0.20070903-1.noarch
    both have file /usr/local/sitebuilder/htdocs/templates/eug-31/info.xml with different md5 sum.
    Warning: packages conflict by files detected: package Cafe_and_Restaurant_pack1-4.1.0.20071205-1.noarch
    conflict with package Cafe_and_Restaurant_pack1-4.0.0.20070903-1.noarch
    both have file /usr/local/sitebuilder/htdocs/templates/xeug-13/info.xml with different md5 sum.
    Warning: packages conflict by files detected: package Educational_pack1-4.1.0.20071205-1.noarch
    conflict with package Educational_pack1-4.0.0.20070903-1.noarch
    both have file /usr/local/sitebuilder/htdocs/templates/vap-58/blue/headers/big/big_headers1.jpg with different md5 sum.
    Warning: packages conflict by files detected: package Fashion_pack2-4.1.0.20071205-1.noarch
    conflict with package Fashion_pack2-4.0.0.20070903-1.noarch
    both have file /usr/local/sitebuilder/htdocs/templates/xeug-03/info.xml with different md5 sum.
    Warning: packages conflict by files detected: package Flowers_pack1-4.1.0.20071205-1.noarch
    conflict with package Flowers_pack1-4.0.0.20070903-1.noarch
    both have file /usr/local/sitebuilder/htdocs/templates/av-073/blue/buttons/buttons1/buttons.xsl with different md5 sum.
    Warning: packages conflict by files detected: package Food_and_Drink_pack1-4.1.0.20071205-1.noarch
    conflict with package Food_and_Drink_pack1-4.0.0.20070903-1.noarch
    both have file /usr/local/sitebuilder/htdocs/templates/av-141/blue/buttons/buttons1/buttons.xsl with different md5 sum.
    Warning: packages conflict by files detected: package Games_pack1-4.1.0.20071205-1.noarch
    conflict with package Games_pack1-4.0.0.20070903-1.noarch
    both have file /usr/local/sitebuilder/htdocs/templates/xet-02/blue/buttons/buttons2/buttons.xsl with different md5 sum.

    ....


    conflict with package sitebuilder_ru_RU-4.0.0-all.07070609.noarch
    both have file /usr/local/sitebuilder/resources/locale/ru_RU/.build with different md5 sum.
    Warning: packages conflict by files detected: package sitebuilder_zh_CN-4.1.0-build07121000.noarch
    conflict with package sitebuilder_zh_CN-4.0.0-all.07070609.noarch
    both have file /usr/local/sitebuilder/resources/locale/zh_CN/.build with different md5 sum.
    Warning: packages conflict by files detected: package sitebuilder_zh_TW-4.1.0-build07121000.noarch
    conflict with package sitebuilder_zh_TW-4.0.0-all.07070609.noarch
    both have file /usr/local/sitebuilder/resources/locale/zh_TW/.build with different md5 sum.
    ERROR: Unable to proceed with the installation until the package MySQL-bench-5.0.27-0.glibc23.i386 is removed from the system.
    Not all packages were installed.
    Please, resolve the above problem and try installing the packages again.
    If you cannot resolve the problem on your own, contact product technical support for assistance.


    Pls help
     
  2. Temka

    Temka Guest

    0
     
    Hi,
    I suppose you can ignore warnings about md5. Read the last message. It contains error
    You need to install this package. Then try to upgrade.
     
  3. dnerty

    dnerty Guest

    0
     
    I thought the same and tried to install it.. But it seems it is already installed. And I must say that Sitebulider 4.0 is running with no problem.

    rpm -i MySQL-bench-5.0.27-0.glibc23.i386.rpm
    /etc/selinux/targeted/contexts/files/file_contexts: Multiple same specifications for /usr/local/lost\+found/.*.
    /etc/selinux/targeted/contexts/files/file_contexts: Multiple same specifications for /usr/local/\.journal.
    /etc/selinux/targeted/contexts/files/file_contexts: Multiple same specifications for /usr/local/lost\+found.
    package MySQL-bench-5.0.27-0.glibc23 is already installed
     
  4. dnerty

    dnerty Guest

    0
     
    Well, i didn't succeed to upgrade sitebuilder. I gave up, because of this mysql error.
    I gave up, because I have mysql installed:
    rpm -qa | grep -i mysql
    MySQL-devel-5.0.45-0.glibc23
    MySQL-shared-5.0.45-0.glibc23
    MySQL-server-5.0.45-0.glibc23
    MySQL-bench-5.0.45-0.glibc23
    MySQL-client-5.0.45-0.glibc23

    SB4.0 was working fine and I didn't push for an upgrade. But from today, SB is not working anymore! This error appears (even I didn't touch SB for months) :

    Internal SiteBuilder error.
    File: /usr/local/sitebuilder/include/SB/Site/ModuleInstancesList.php; Line: 76
    Message: Module with instance id='t5zy9rqdp48' does not exists.; Code: 0

    I tried again to upgrade SB, but of course, SB says I dont have MySQL installed :).
    I uninstalled SB and tried ti install 4.2 or 4.0 but nothing.

    Never have had so much problems with some software in my life. Everybody be aware, you will have problem with SB soon or later, think twice before install it.
    Sorry guys..
     
  5. Dmitry Frantsev

    Dmitry Frantsev Golden Pleskian

    28
    57%
    Joined:
    Sep 19, 2005
    Messages:
    1,911
    Likes Received:
    0
    If you are sure that MySQL configuration is correct on the server and MySQL service is running fine I suggest you install Sitebuilder packages with '--nodeps' option. This will disable checking dependencies and Sitebuilder should be installed fine. Hope it helps.
    As I remember there were some issues related to supporting only MySQL packages from vendors, but this should be solved in latest version. If you installing Sitebuilder with help of autoinstaller, could you please attach here /tmp/autoinstaller3.log file right after installation try.
     
Loading...