1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Upgrade failed 9.5.2 --> 9.5.3 psa-mail-driver-common: package dependencies

Discussion in 'Plesk 9.x for Linux Issues, Fixes, How-To' started by CharisM, Aug 16, 2012.

  1. CharisM

    CharisM New Pleskian

    14
    35%
    Joined:
    Aug 16, 2012
    Messages:
    19
    Likes Received:
    2
    Looking for help on how to solve the following problem: while upgerading via ssh or also via Plesk Admin Panel the upgrade process is interrupted with the following message:


    Execute command rpm -U --test /root/psa/PSA_9.5.3/dist-rpm-SuSE-11.1-i386/opt/vz/psa-backup-manager-vz-9.5.3-suse11.1.build95101022.06.i586.rpm /root/psa/PSA_9.5.3/dist-rpm-SuSE-11.1-i386/opt/backup/psa-backup-manager-9.5.3-suse11.1.build95101022.06.i586.rpm /root/psa/PSA_9.5.3/dist-rpm-SuSE-11.1-i386/opt/api/psa-api-rpc-9.5.3-suse11.1.build95101022.06.noarch.rpm /root/psa/PSA_9.5.3/dist-rpm-SuSE-11.1-i386/base/psa-9.5.3-suse11.1.build95101022.06.i586.rpm /root/psa/PSA_9.5.3/dist-rpm-SuSE-11.1-i386/opt/migration/psa-migration-manager-9.5.3-suse11.1.build95101022.06.i586.rpm /root/psa/PSA_9.5.3/dist-rpm-SuSE-11.1-i386/base/psa-api-9.5.3-suse11.1.build95101022.06.noarch.rpm /root/psa/PSA_9.5.3/dist-rpm-SuSE-11.1-i386/base/psa-libpam-plesk-9.5.3-suse11.1.build95101022.06.i586.rpm /root/psa/PSA_9.5.3/dist-rpm-SuSE-11.1-i386/base/psa-locale-base-en-US-9.5.3-2010071512.noarch.rpm /root/psa/PSA_9.5.3/dist-rpm-SuSE-11.1-i386/base/plesk-skins-9.5.3-0.293097.noarch.rpm /root/psa/PSA_9.5.3/dist-rpm-SuSE-11.1-i386/base/psa-updates-9.5.3-suse11.1.build95101022.06.noarch.rpm
    error: Failed dependencies:
    psa-mail-driver-common < 9.5.3 conflicts with psa-9.5.3-suse11.1.build95101022.06.i586
    -- Check for new version of PSA_9.5.3/plesk-9.5.3-suse11.1-i386.inf3
    Filefetcher: get file (~empty)/PSA_9.5.3/plesk-9.5.3-suse11.1-i386.inf3
    Error: Unable to install the requested packages because either there is
    not enough free disk space left, or there are package dependency problems.
    Warning! Not all packages were installed.


    There is enough disk space. Could anyone tell me how to solve the dependeny problem and how the commands have to like to to do? I really appreciate this.

    thanks in advance, c--
     
    Last edited: Aug 16, 2012
  2. CharisM

    CharisM New Pleskian

    14
    35%
    Joined:
    Aug 16, 2012
    Messages:
    19
    Likes Received:
    2
    who is interersted in it: I solved that by

    rpm -Uvh --force path/to/the/PSA953/Suse/opt/maildrivers/package.rpm

    Updated to 9.5.3
     
  3. IgorG

    IgorG Forums Analyst Staff Member

    49
    24%
    Joined:
    Oct 27, 2009
    Messages:
    24,557
    Likes Received:
    1,242
    Location:
    Novosibirsk, Russia
    Why to 9.5.3? It is very-very old Plesk version.
     
  4. CharisM

    CharisM New Pleskian

    14
    35%
    Joined:
    Aug 16, 2012
    Messages:
    19
    Likes Received:
    2
    right. it was just on the way up tp 10.1.1. i am late anytime.... i know
     
  5. abdi

    abdi Platinum Pleskian

    31
    18%
    Joined:
    May 14, 2006
    Messages:
    2,913
    Likes Received:
    60
    An upgrade is highly recommended!
     
  6. CharisM

    CharisM New Pleskian

    14
    35%
    Joined:
    Aug 16, 2012
    Messages:
    19
    Likes Received:
    2
    yes, that's right. i am on 10.1 now. Further upgrades are not provided by Strato
     
  7. CharisM

    CharisM New Pleskian

    14
    35%
    Joined:
    Aug 16, 2012
    Messages:
    19
    Likes Received:
    2
  8. IgorG

    IgorG Forums Analyst Staff Member

    49
    24%
    Joined:
    Oct 27, 2009
    Messages:
    24,557
    Likes Received:
    1,242
    Location:
    Novosibirsk, Russia
  9. CharisM

    CharisM New Pleskian

    14
    35%
    Joined:
    Aug 16, 2012
    Messages:
    19
    Likes Received:
    2
    yes, now it is working. updated successfully. thx
     
Loading...