1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice

Upgrade

Discussion in 'Plesk for Linux - 8.x and Older' started by tytanic11, Jan 6, 2005.

  1. tytanic11

    tytanic11 Guest

    0
     
    I've been trying to upgrade to the new 7.5.1 version of plesk reloaded, but it fails with this error :

    "Installing php-pgsql-4.3.4-11.i386.rpm
    warning: /root/psa/PSA_7.5.1/FC2_std.updates/php-pgsql-4.3.4-11.i386.rpm: V3 DSA signature: NOKEY, key ID 4f2a6fd2
    error: Failed dependencies:
    php = 4.3.4-11 is needed by php-pgsql-4.3.4-11"

    We're currently using a newer version of php (4.3.8), and we don't need this php-pgsql package anyway (we don't even have pgsql installed - we only use mysql) - The only reason it tries to install that package is that it's 'required for the base packages' - is there any way to work around this ?

    Thanks,
    -Tyler
     
  2. murali.r

    murali.r Guest

    0
     
    Try this.....

    run "rpm -e php-pgsql-4.3.4-11", then try upgrade as "rpm -Uvh *" in the base
    directory.

    I believe you upgrade plesk using the option "rpm -Uvh *" in the base directory.
    You can use the --force option to upgrade plesk as "rpm -Uvh --force *" in the
    base directory.
     
  3. tytanic11

    tytanic11 Guest

    0
     
    sorry to sound like an idiot here, but what is the 'base directory' ?
     
  4. murali.r

    murali.r Guest

    0
     
    When you upzip the plesk package, you will see 2 the directory rpm_RedHat9.x. When you change to that directory you can see the directories named "base" and "opt", where the rpms in the base directories are MUST installed rpms and the rpms in the opt dir are plesk add-ons.

    Hope you understand.
     
  5. akucharski

    akucharski Guest

    0
     
    did this work

    Did this work? I am having a similar problem
     
Loading...