1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Upgraded to MySQL 4.1.18, but Plesk won't detect it

Discussion in 'Plesk for Linux - 8.x and Older' started by orpheum, Feb 23, 2006.

  1. orpheum

    orpheum Guest

    0
     
    Hi everyone,

    I upgraded from MySQL 3.23 to MySQL 4.1.18 manually using the RPMs at MySQL's website, and then went off without a hitch (for the most part). The only problem now is that Plesk cannot detect the new MySQL installation.

    If I go into the admin control panel and check Component Info, it says that MySQL isn't installed.

    Is there anyway to point Plesk in the right direction so that it CAN see MySQL 4? Thanks in advance.
     
  2. vasillalov

    vasillalov Guest

    0
     
    The only thing I can think of is to check your /etc/init.d/ folder.

    Depending on the version of MySQL, the init script is sometimes labled as mysql instead of mysqld

    That means that you no longer start MySQL with
    /etc/init.d/mysql start

    but with

    /etc/init.d/mysqld start

    try renaming the script from mysql to mysqld or vice versa.

    I hope this helps...
     
  3. Highland

    Highland Guest

    0
     
    You're a brave man. I tried the RPM route and Plesk crashed and burned on me. Whatever you do don't reboot or you'll never get Plesk back up. I'm uninstall the RPM ASAP and go with a yum install instead. Art is up to 4.1.15 last I checked.
     
  4. orpheum

    orpheum Guest

    0
     
    Highland, I actually didn't have that problem at all. I've restarted the server a couple of times since then, no problems at all.

    vasillalov, thanks for the advice. I'll give it a shot and let you know if it worked.
     
  5. orpheum

    orpheum Guest

    0
     
    Darn it, it didn't work. It still started MySQL, thankfully, but didn't make a difference as to whether or not Plesk could see that it's installed/running.

    Any other suggestions?
     
  6. orpheum

    orpheum Guest

    0
     
  7. simonp@

    simonp@ Guest

    0
     
    hi,

    if you havfe haven't already - you should make sure that you modify '/etc/psa/psa.conf' to point to where MYSQL now is.

    look for these lines & edit
    # MYSQL
    MYSQL_VAR_D /var/lib/mysql
    MYSQL_BIN_D /usr/bin

    Simon
     
Loading...