1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

URGENT: Qmail not sending emails

Discussion in 'Plesk for Linux - 8.x and Older' started by ray201, Sep 26, 2006.

  1. ray201

    ray201 Guest

    0
     
    Hi,

    I have some problems with my qmail on Plesk 8.0.1 not sending any emails at all. Right now i've got over 5000 emails sitting in my remote queue and growing rapidly.

    Most of the emails are failure notices, and unimportant stuff. But I've created a test account on one of my test domains (test@westvik.net) to try and send from.

    If i send to anohter email i've got (ray@airmail.no) i get:
    553 sorry, that domain isn't in my list of allowed rcpthosts (#5.7.1)

    I am not too familiar with mailsetup and how this should work. My whitelist it set to: 127.0.0.1/32 as recommended by this forum. I have no entries in my blacklist.

    Also if i try sending an email to a domain hosted on my Plesk server it stops in the remote queue.

    One thing i did descover and have fixed was that my Plesk server was for some reason not able to lookup domains. I have made changes to /etc/resolve.conf and i can again ping whatever.com
    I have not rebooted but runned killall -HUP qmail-remote and named after this.

    Is there any way i can open qmail to stop checking for the recipients?

    Has anyone had this problem before?

    I have searched the forums, but don't understand much of it.

    My remote queue is now holding messages up to 7 days 4 hours and 51 minutes old.
    If i can remember correctly we ran a Plesk update around this time.

    Thanks for reading
     
  2. simpliq_adi

    simpliq_adi Guest

    0
     
    Hello,

    Try this logged as root:

    /usr/local/psa/admin/sbin/mchk --with-spam

    then restart qmail:

    /etc/init.d/qmail restart

    Also check if mail is enabled for that domain in Plesk.
     
  3. ray201

    ray201 Guest

    0
     
    Hi, thanks for your reply.

    the issue is resolved. it was DNS related.

    Cheers
     
  4. jonnymcalister

    jonnymcalister Guest

    0
     
    hi, having same problem myself is there any way you could post the solution please??
    cheers
    Jonny
     
  5. ray201

    ray201 Guest

    0
     
    Hi,

    My problem was DNS resolution. And if you have the same problem yours might be as well.

    Confirm that DNS is working (nslookup -type=MX somedomain.com). If its not simply add a decent dns server into /etc/resolve.conf

    Restart qmail services and email should start to dissapear.
     
  6. amphora

    amphora Guest

    0
     
    I'm having the same problem.
    My remote qmail queue is growing
    But DNS seems to work fine.

    nslookup -type=MX domain.nl (where domain.nl is the domain I want to sent mail to) gives me:

    Non-authoritative answer:
    domain.nl mail exchanger = 30 mail.domain.nl.

    mail.domain.nl is also resolvable

    telnet mail.domain.nl 25 also connects to remote smtp service.

    Allready ran /usr/local/psa/admin/sbin/mchk --with-spam but that didn't help either.
    Even rebooted server afterwards.

    Please help me.
     
  7. amphora

    amphora Guest

    0
     
    Figured it out I guess:

    editing (or creating) /var/qmail/control/concurrencyremote seems to have helped. I use a value of 255 now.
     
Loading...