• Debian 11 has reached its end-of-life (vendor EOL date - August 31, 2026). Plesk Obsidian 18.0.81 is the last release to support it.
    If you are running Plesk Obsidian on Debian 11, we recommend you upgrade those servers to Debian 12 using our dist-upgrade tool.
  • We plan to deprecate and remove the support for XML RPC protocol versions earlier than 1.6.9.1 in Plesk Obsidian 18.0.82. We strongly recommend that you update all existing integrations using earlier versions of the XML RPC protocol to comply with the version 1.6.9.1 specification.

Question usr/local/psa/ is missing on plesk 12.5 after an update

Gopi Adusumilli

New Pleskian
The usr/local/psa/ is missing.

Is there a way to restore the folder or do I need to restore the image and rebuild the server.


Thanks in Advance

gopi
 
Do you have Ubuntu/Debian? In this case location is /opt/psa/ Check it. But if you completely lost /usr/local/psa/ directory with all content - it means that your Plesk is completely damaged. Note, this can never happen after Plesk upgrade procedure, even after the most unsuccessful.
So, anyway, I think that you need to restore the image and rebuild the server.
 
Thank you very much. I found the files in '/opt/psa/' and ran '/opt/psa/admin/sbin/autoinstaller' which brought the Plesk back online and all the sites started working for like 15 minutes and it went down with DB error so I ran Plesk repair all and it fixed Plesk but could not start Apache. The error message says, 'NO MPM module loaded'. So I tried to fix it and now MySQL won't start. So looks like I have to restore the image and rebuild the server.
 
I would suggest you fix your Plesk with

# plesk installer --select-release-current --reinstall-patch --upgrade-installed-components
# plesk repair installation
 
Back
Top