1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Webadmin problem - 500 Internal Server Error

Discussion in 'Plesk 10.x for Windows Issues, Fixes, How-To' started by alican, Aug 29, 2011.

  1. alican

    alican Guest

    0
     
    Hi, What's up everyone?

    I've Windows Server 2008 Web Edition with Plesk 10.3.0 server and I'm using it with SQL 2005.
    I just install plesk on my totally clean/fresh server but I can't access webadmin (asp .net enterprise manager). I mean when I try to open it up, it's shows up Internal Error 500 and it goes this url: http://mssql.MYDOMAIN.com/mssql/app/connect.aspx

    looks like a permission problem but I'm really new with Windows and Plesk panel.

    Could you please tell me what's wrong with me? :)
    Cheers,
    Alican
     
  2. SvetlanaS

    SvetlanaS Regular Pleskian

    16
    30%
    Joined:
    Sep 5, 2011
    Messages:
    110
    Likes Received:
    0
    check permissions for C:\inetpub\vhosts\sqladmin\mssql folder : grand read, execute for psacln
     
  3. OrionHat

    OrionHat Guest

    0
     
    Permissions

    I have checked permissions for C:\inetpub\vhosts\sqladmin\mssql folder : grand read, execute for psacln, but it still doesn't. I still can't access webadmin and I see error message:

    500 - Internal server error.
    There is a problem with the resource you are looking for, and it cannot be displayed.
     
  4. Mike Legg

    Mike Legg Basic Pleskian

    18
    85%
    Joined:
    Dec 19, 2010
    Messages:
    91
    Likes Received:
    0
    I have the same problem on Plesk 10.3.1 and I've granted read and execute permissions on the D:\inetpub\vhosts\sqladmin\mssql folder to psacln.
     
  5. SvetlanaS

    SvetlanaS Regular Pleskian

    16
    30%
    Joined:
    Sep 5, 2011
    Messages:
    110
    Likes Received:
    0
    1. Report more detailed IIS error: browse sqladmin site locally (via IIS).
    2. Check "Tools&Setting"->server components->Microsoft SQL Webadmin. Make shure that ASP.NET Enterprise Manager is installed.
    Also if you have an instance of MSSQL 2005 you can switch Microsoft SQL Webadmin to "MS SQL 2005 server support" it should resolve this issue.
     
  6. OrionHat

    OrionHat Guest

    0
     
    Application Pool

    I have solved it. My problem was related to Application Pool. I accessed IIS, and changed Application Pool on sqladmin and mssql by clicking on Basic Settings. This procedure is for IIS 7.
     
  7. Mike Legg

    Mike Legg Basic Pleskian

    18
    85%
    Joined:
    Dec 19, 2010
    Messages:
    91
    Likes Received:
    0
    What pool did you change it to?

    sqladmin is currently using plesk(default)(2.0)(pool) on my server.

    The full error that I'm getting is
    Yet psacln does have read permissions on that file.
     
  8. Mike Legg

    Mike Legg Basic Pleskian

    18
    85%
    Joined:
    Dec 19, 2010
    Messages:
    91
    Likes Received:
    0
    Looks like this problem is not new - http://forum.parallels.com/showthread.php?t=111541

    I've tried all of the suggestions but I still can't get it to work.

    Now instead of a permissions error I get a blank screen. When I view the html source I see this ...

    <html>
    <head>
    <meta http-equiv="X-UA-Compatible" content="IE=7"/>
    </head>
    <body onLoad="document.forms[0].submit();">
    <form action="http://mssql.domain.tld/mssql/app/connect.aspx" method="post">
    <input type="hidden" name="DataSource" value=".\MSSQLSERVER2008">
    <input type="hidden" name="Port" value="">
    <input type="hidden" name="UID" value="xxxxxxxx">
    <input type="hidden" name="PWD" value="xxxxxxxx">
    </form>

    </body>
    </html>
     
    Last edited: Sep 22, 2011
  9. OrionHat

    OrionHat Guest

    0
     
    Blank Screen

    If you changed Application Pool, the Application Pool you have chosen may be interpreting .asp and .aspx pages as html.

    Take a look on Handler Mappings and see if there are handlers enabled for .asp and .aspx.

    Answering your question about which pool I was using, when I got the error I first selected DefaultAppPool and it worked, but now I am able to use plesk(default)(2.0)(pool).
     
Loading...