1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Webalizer doesn't work after updating to 8.0.1

Discussion in 'Plesk for Linux - 8.x and Older' started by jhuedder, Jun 18, 2006.

  1. jhuedder

    jhuedder New Pleskian

    22
    73%
    Joined:
    Sep 23, 2004
    Messages:
    24
    Likes Received:
    0
    Hi,

    I was running 8.0.0 on SuSE 10.0 and did the 8.0.1 update. Everything worked fine except the usage statistics with Webalizer. Statistics aren't calculated any more.

    When I run "/usr/local/psa/admin/sbin/statistics --calculate-all" manually I get the error "statistics: unable to get database status for xyz-form: You have an error in your SQL syntax: check the manual that corresponds to your MySQL server version for the right syntax to use near '-forum' at line 1".

    I'm running MySQL 4.1.13.

    Any ideas?

    Thanks, Jörg (info(at)hueddersen.de)
     
  2. acer

    acer Guest

    0
     
    same here... webstats not working after 8.01 upgrade
     
  3. skellenb

    skellenb New Pleskian

    24
    40%
    Joined:
    Jan 21, 2005
    Messages:
    15
    Likes Received:
    0
    i had the same problem after updating to 8.0.1

    The error message only occured by Domains with MySQL DB's with a name containing a "-" in the DB-Name

    somthing like this:
    Code:
    statistics: Unable to get database status for "joomla-940510481": 
    You have an error in your SQL syntax; 
    check the manual that corresponds to your MySQL server version for the right syntax to use near '-940510481' at line 1
    After renaming the DB's to a name without "-" in it, it seems to work for now...

    But when you have 100's of Customers... tell me, how can i explain all the customers not to use the "-" ??? :confused: :confused:
     
  4. jhuedder

    jhuedder New Pleskian

    22
    73%
    Joined:
    Sep 23, 2004
    Messages:
    24
    Likes Received:
    0
    skellenb you're right: I can't tell all my customers not use use '-' in future and I also can't ask all of them to change their database-names now. Imagine the amount of work to change all shops, forums, etc.
     
  5. crnunez

    crnunez Regular Pleskian

    25
    90%
    Joined:
    May 24, 2006
    Messages:
    124
    Likes Received:
    0
    I think that all Plesk's users should be request AWSTATS and nevermore the terrible and deprecated webalizer.

    My cent for AWSTATS, it's really good!
     
  6. gijsbert

    gijsbert Basic Pleskian

    26
    57%
    Joined:
    Aug 22, 2001
    Messages:
    83
    Likes Received:
    0
    Same problem here. Did anyone receive a fix from plesk for this?

    In case you didn't know: If you want to run webalizer for non-problematic domains, simply use:

    /usr/local/psa/admin/sbin/statistics --calculate-one --domain-name=<domainname>

    Gijsbert
     
  7. ideasmultiples

    ideasmultiples Basic Pleskian

    25
    73%
    Joined:
    May 19, 2004
    Messages:
    83
    Likes Received:
    0
    If are a DB whit "-" in name statistics dead, is a error from PLESK, resolved in next release
     
  8. Traged1

    Traged1 Guest

    0
     
    That is not good enough, we need our stats, thousands of customers are calling us reporting that thier webstats are no longer working, what do I tell them, that it will be fixed sometime in the future??? This is not acceptable, we need the fix NOW!
     
  9. Traged1

    Traged1 Guest

    0
     
    Contacting PLESK support on this issue now.. I will re-post when a solution or work around is found.
     
  10. Mark Priest

    Mark Priest Guest

    0
     
    I was promissed AWSTATS in the 8.01 update months ago and it seems it never appeared!
     
  11. gijsbert

    gijsbert Basic Pleskian

    26
    57%
    Joined:
    Aug 22, 2001
    Messages:
    83
    Likes Received:
    0
    Curious what PLESK support told you. I don't understand why they don't release a fix. It doesn't have to be a new release of plesk. I believe a simple bash/perl-script to correct this error will do.
     
  12. Traged1

    Traged1 Guest

    0
     
    Support has provided me with a new/patched statistics binary file. I am sure that if you also contact support they will provide this file to you, and as soon as many of us ask for the file it will be made available on the ftp pub.
     
Loading...