• Debian 11 has reached its end-of-life (vendor EOL date - August 31, 2026). Plesk Obsidian 18.0.81 is the last release to support it.
    If you are running Plesk Obsidian on Debian 11, we recommend you upgrade those servers to Debian 12 using our dist-upgrade tool.
  • We plan to deprecate and remove the support for XML RPC protocol versions earlier than 1.6.9.1 in Plesk Obsidian 18.0.82. We strongly recommend that you update all existing integrations using earlier versions of the XML RPC protocol to comply with the version 1.6.9.1 specification.

Websites not working

Mike Stone

New Pleskian
Hi all

After rebooting my server, my websites are no longer working.

If I access the plesk machine on the local network by it's hostname, the default Plesk page shows as expected. Everything on 8443 works too.

All hosted sites do not work. FTP DOES work. This seems limited to an http problem of some sort.

I do not know where to start looking so if anyone can help me out, it'd be very appreciated!

Thanks
Mike
 
Continuing my investigation, it is surely tied to https. Non ssl works fine. I suspect there is some issue with a conf that was maybe overwritten or something from an update?
 
Have you tried

# /usr/local/psa/admin/bin/httpdmng --reconfigure-all

at least?
 
Hi IgorG. I did run all those commands. I found them in another thread. They did not change anything unfortunately.
 
I cannot access any site via https. All sites do work with http.

The error chrome gives is ERR_CONNECTION_RESET
 
ERR_CONNECTION_RESET may be caused by many reasons and this issue has been discussed here a lot of times. Try to use forum search engine and read these discussions for extracting appropriate solution.
 
Have you tried check it with other browsers?
I can only recommend to create a request to support team to do in-depth investigation to find the reason and to fix it. Please create a ticket to support at https://www.odin.com/support/request/ .
You may have free support, please check what kind of Plesk license you use for available support options at http://kb.odin.com/en/121580 .
If there’s no free support in your case, you can order Plesk per-incident support at http://www.odin.com/support/buy-support/ Support team will contact you as soon as purchase is processed, and they will do the best to resolve it.
If it is found that your problem was caused by product bug w/o available solution or workaround from Parallels, then your purchase will be re-funded.
 
I do have one issue in the boot log I just found.
* Starting internet superserver xinetd [fail]

Any thoughts there?
 
A shot in the dark but there may have been some SSL changes made to a .conf file which weren't applied without the restart and they could be causing connection attempts over SSL to fail
 
Back
Top