1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Whitelist an IP Address

Discussion in 'Plesk for Linux - 8.x and Older' started by benc@, Feb 3, 2007.

  1. benc@

    benc@ Guest

    0
     
    Hi,

    I am trying to set up my server to allow my friends server (which is hosted on an adsl connection, and blocked by ip range on many RBL lists) to relay through my server.

    I have added his IP to the White List in Server->Mail->Whitelist, but the the spam protection I have on my server, using the built in RBL lists are stopping him from connecting to be able to send email.

    Is there a way I can configure my server to allow his connection by IP address, even though his IP is blocked by the RBL's I have in my spam protection.

    Thanks

    Ben
     
  2. jwdick

    jwdick Guest

    0
     
    You can edit the /etc/xinetd.d/smtp_psa file and the smtps_psa file. Add -a <ip> to
    exclude the IPs which you dont want to be blocked by the RBL lists:

    e.g:
    server_args = -Rt0 /usr/sbin/rblsmtpd -a xx.xx.xx.xx -r relays.ordb.org .........

    restart xinetd.d with:

    /etc/rc.d/init.d/xinetd restart
     
  3. skrieg2

    skrieg2 Guest

    0
     
    Hi,

    Is there a way for authenticated users to use the mail server even if their IP is listed ?

    If not possible, the rbl system is impossible to use.
     
  4. DCoats

    DCoats Guest

    0
     
    Anyone else know how this is done? I use freeBSD and I can edit /etc/inetd.conf with the -a options but everytime you restart qmail plesk overwrites the line. also you are limited to how many you can add, because of argument limitations.
    inetd[1482]: /etc/inetd.conf: too many arguments for service smtp
    inetd[1482]: /etc/inetd.conf: too many arguments for service smtps
     
  5. dirty@

    dirty@ Guest

    0
     
    if I am not wrong rblsmtpd checks for sender IP and declines it in the very beginning of smtp session, before connection is taken by qmail-smtpd.. so that there are no way to pass smtp authorization first
     
  6. DCoats

    DCoats Guest

    0
     
    Hi Dirty,
    Thanks for the reply, I figured out this one already, what I did to bypass this for clients who's ip's are listed in RBL's.

    created a new service for smtp in /etc/inetd.conf
    call it whatever you like, in my case I called it smtp_alt and added the same plesk smtp line without the RBL's added to it. Then added smtp_alt into /etc/services and choose a different smtp port for special clients to use. Notified special clients to use the alt port for sending mail to bypass the rbl lookup.
     
Loading...