1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

WWW prefix not being added to "httpd.include"

Discussion in 'Plesk for Linux - 8.x and Older' started by fivenines1, Dec 20, 2006.

  1. fivenines1

    fivenines1 Guest

    0
     
    Hello all,

    I have been using Plesk for over a year now (psa v8.1.0_build81061212.22 os_FedoraCore 2) but have recently upgraded to a better server (v8.1.0_build81061212.22 os_FedoraCore 4)

    My first experience with the Migration Manager tool went fine (the domain is practically empty and unused). The second domain that I migrated over would not show when using http://www.domain.com but was fine with http://domain.com

    I then tried setting up another domain from fresh - this also would not show when using http://www.domain.com but was fine with http://domain.com

    I searched this site for answers, and have successfuly edited the "httpd.include" within var/www/vhosts/domain.com/conf to include:

    ServerAlias www.pinfoldcottage.com
    UseCanonicalName Off

    - and reset Apache, which then works fine... but surely this can't be the answer, to edit the httpd.include for each domain that I transfer or setup from new??? (i have about 56 to go!)

    It just seems odd that the first domain worked fine... but now all domains are created without the Serveralias in the httpd.include file?

    Has anyone got any ideas why this is happening? Or even better - a way to fix it!??!

    Many thanks

    Mik
     
  2. fivenines1

    fivenines1 Guest

    0
     
    so... further development!

    it turns out that the newly added domain was just a bit slow in updating DNS... BUT the issue still stands that if the domain is migrated from the old server - I DO need to amend the httpd.include with the Domainalias.

    Am I doing something wrong here? I migrate with the standard settings - and have tried migrating several domains (separately) but still get the same issues.

    Anyone? Help... Please!
     
  3. webhilfe

    webhilfe Guest

    0
     
    we have the same error on Debian 3.1.

    Please fix the error SW-Soft!
     
  4. blank_page

    blank_page Regular Pleskian

    24
    53%
    Joined:
    Dec 17, 2006
    Messages:
    229
    Likes Received:
    0
    Hello,


    Did you check the Domain administrator section if the www is checked?

    If not check it.

    Also what page was displayed when entered http://www.domain.com ?
    Not found or default plesk page?
     
  5. webhilfe

    webhilfe Guest

    0
     
    Fixed!

    thank you blank_page!

    this was the right way. I have unchecked the www box -> save, (look at httpd.include whether it works corectly) then i have checked the www box -> save. I use the Domain Group operations for all Domains. Now i hope it works :)
     
  6. fire692

    fire692 Guest

    0
     
    Just an FYI that I had the same problem (seeing default PLESK page) but "www" was already checked in the Domain Administrators section in PLESK. I removed "www", then saved, then re-checked the "www" option and saved again.

    I then stopped and restarted apache and this worked for me.
     
Loading...