1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Zend Guard Loader. It is possible to install?

Discussion in 'Plesk 10.x for Linux Issues, Fixes, How-To' started by SalvadorS, Mar 21, 2012.

  1. SalvadorS

    SalvadorS Regular Pleskian

    29
    90%
    Joined:
    Nov 12, 2009
    Messages:
    282
    Likes Received:
    2
    Hello,

    I have a server with Debian 64bits, Plesk 10.4.4, PHP 5.3.3

    I downloaded Zend Guard Loader from zend.com webpage and followed the instructions to install it.

    I added these lines to my php.ini

    [Zend.loader]
    zend_extension=/usr/local/lib/zend/ZendGuardLoader.so
    zend_loader.enable=1
    zend_loader.disable_licensing=0
    zend_loader.obfuscation_level_support=3
    zend_loader.license_path =

    And then restart apache

    The problem is when I restart apache, CPU usage goes to 100% and the server does not work. I have to edit again php.ini, disable the Zend Guard lines and restart apache again.

    So my question is

    Does anyone install Zend Guard Loader in a box with Plesk 10.4.4 and php 5.3.3?

    How?

    Thanks a los
     
  2. TimU

    TimU New Pleskian

    15
    85%
    Joined:
    May 11, 2010
    Messages:
    5
    Likes Received:
    0
    I have a similar but different issue. Rather than have CPU climb to 100% I get seg faults.

    I have opened the discussion over on Zend's forums as well in the event that it is an issue with their product but has anyone found a way for a Plesk 10.x, PHP 5.3, RHEL 6 server to use Zend Guard Loader?
     
  3. SalvadorS

    SalvadorS Regular Pleskian

    29
    90%
    Joined:
    Nov 12, 2009
    Messages:
    282
    Likes Received:
    2
    Hello,

    I fixed myself the problem. Here you have the steps to fix it.

    The problem is with the load of ioncube and Zend Guard Loader. To fix it edit the file:

    /etc/php5/conf.d/ioncube-loader-5.3.ini

    And add the line:

    zend_extension=/usr/local/lib/zend/ZendGuardLoader.so

    Below the line

    zend_extension=/usr/lib/php5/20090626/ioncube_loader_lin_5.3.so

    (I asume you install ZendGuardLoader.so in /usr/local/lib/zend path)

    Then restart apache

    /etc/init.d/apache2 restart

    And done!
     
    Last edited: Mar 29, 2012
  4. smisonline2

    smisonline2 New Pleskian

    10
     
    Joined:
    Oct 1, 2012
    Messages:
    1
    Likes Received:
    0
    php.ini?

    must the

    include path stay in the php.ini or must it removed?
     
Loading...