1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice

Can't log in to Remote Admin

Discussion in 'Legacy Sitebuilder Software' started by dario, Oct 21, 2005.

  1. dario

    dario Guest

    0
     
    Geez... I've just upgraded to Sitebuilder 2.1.1 from 2.0.0 and installed the Remote Admin module. When I try to access address

    http://mysite/remote_admin/script.php

    I'm asked for a user name and password. The manual suggests I use "root" and "reseller" on those fields, respectively, but I just can't log in! I've tried the root password for the Sitebuilder admin interface, root/root, root/sitebuilder, root/Reseller, Root/Reseller, root/admin, admin/admin, admin/sitebuilder, but NOTHING!!! I'm puling all my hair out, please help! I've created a reseller account, but the user name and password don't work either. The SB administration interface has no knowledge of the Remote Admin module, so I can't reset the password. How can I do that? I'm about to shoot myself!

    Thanks
    Dario
     
  2. dario

    dario Guest

    0
     
    Ok! Here's the deal: my PHP is running as CGI, through PHPSuexec, which ruins the support for HTTP authentication in PHP. Once I put PHP back as Apache module, I was able to authenticate successfully at the Remote Admin directory. Well, I thought SW-Soft's development team was smart enough to NOT use HTTP auth with PHP scripts, since they ARE aware that many Cpanel systems use PHPSuexec (refer to http://faq.sw-soft.com/article_5_834_en.html)!

    Can anyone that's got a support contract with SW-Soft send this info to them? Thanks a lot!

    Dario
     
Loading...