1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Can't restore converted Plesk 8.1 Backup to Plesk 9.3

Discussion in 'Plesk 9.x for Linux Issues, Fixes, How-To' started by japanitrat, Jun 16, 2010.

  1. japanitrat

    japanitrat Guest

    0
     
    Hi,

    I just reinstalled my server and tried to restore a previously made server-wide Plesk8 backup in Plesk9. I did as told in the migration guide: created a backup in Plesk8 with the "pleskbackup all <file>", converted it with "pre9-backup-convert convert -d /var/lib/psa/dumps <file>" and tried to restore it with "pleskrestore --restore /var/lib/psa/dumps/<backup>.xml -level server"

    Unfortunately, pleskrestore responds with:
    So I tried it with --check-backup command which also says "Backup file has wrong format". On the other hand, when I use pleskrestore with the -i option, it seems to understand at least the backup-structure. Output:

    How can I fix this ASAP?
     
    Last edited by a moderator: Jun 16, 2010
  2. japanitrat

    japanitrat Guest

    0
     
    As mentioned in http://kb.odin.com/en/6080, I ran "xmllint --noout -schema /usr/local/psa/PMM/plesk.xsd /var/lib/psa/dumps/converted_info_1006161142.xml".

    Output was:
    I removed the element and it the backup now shows up as valid. I tried to restore it, but it seems that the "suspend" option does not work, so the domains become accessible when I am restoring the backup .. furthermore (maybe for this reason), my databases are not restored at all!

    So, up to this point I got everything running, except the databases. No errors are thrown, what could it be?
     
    Last edited by a moderator: Jun 16, 2010
  3. redline

    redline New Pleskian

    22
    73%
    Joined:
    Mar 25, 2007
    Messages:
    13
    Likes Received:
    0
    i had the same problem i removed the element and now its showing this :(
    wpc4817:/opt/psa/bin# xmllint --noout -schema /usr/local/psa/PMM/plesk.xsd /var/lib/psa/dumps/converted_info_1008150745.xml
    /var/lib/psa/dumps/converted_info_1008150745.xml validates
    wpc4817:/opt/psa/bin# ./pleskrestore --restore /var/lib/psa/dumps/converted_info_1008150745.xml -level server -license -verbose
    Backup file has wrong format
    Dump has critical errors.

    wpc4817:/opt/psa/bin#



    dont know what to do
     
    Last edited: Aug 15, 2010
Loading...