1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Can't Upgrade

Discussion in 'Plesk 10.x for Linux Issues, Fixes, How-To' started by deeplist, Nov 5, 2010.

  1. deeplist

    deeplist Guest

    0
     
    I attempted to upgrade to plesk 10 today and received the following:

    Setting up Install Process
    No package plesk-core available.
    No package plesk-l10n available.
    Package mod_fcgid-2.3.5-2.el5.art.x86_64 already installed and latest version
    No package psa-triggers available.
    No package psa-vhost available.
    No package pp-sitebuilder available.
    No package pp-sitebuilder-default-templates available.
    No package pp-sitebuilder-skins available.
    No package plesk-mail-qc-driver available.
    No package psa-courier-imap available.
    Package matching psa-kronolith-2.1.8-2.el5.art.noarch already installed. Checking for update.
    Nothing to do
    The packages were installed successfully.


    What is the problem?
     
  2. deeplist

    deeplist Guest

    0
     
    Now I am receiving the following:

    psa-10.0.1-rhel5.build109101029.19.x86_64 from plesk1001 has depsolving problems
    --> Missing Dependency: pp-sitebuilder >= 5.0.0 is needed by package psa-10.0.1-rhel5.build109101029.19.x86_64
    Error: Missing Dependency: pp-sitebuilder >= 5.0.0 is needed by package psa-10.0.1-rhel5.build109101029.19.x86_64
     
  3. deeplist

    deeplist Guest

    0
     
    Wow, 3 days now and not so much as a lick of help from anybody.
    What a sad excuse for a PAID software support forum!
     
  4. ChrisKMEX

    ChrisKMEX New Pleskian

    15
    85%
    Joined:
    Nov 10, 2010
    Messages:
    9
    Likes Received:
    0
    same here

    Same here, any suggestion??

    There was a package dependency problem. The message was:

    Unresolvable chain of dependencies:
    psa-10.0.0-rhel4.build108101004.13 requires pp-sitebuilder >= 5.0.0


    9.5.3 to 10.0.0.0
     
  5. deeplist

    deeplist Guest

    0
     
    I received no help from this forum at all. After 3 days of messing with it, I finally got plesk to upgrade.

    I had to manually download three RPM packages with WGET and force them to install with --nodeps. They are:
    pp-sitebuilder-5.0.0-33387.10092415.noarch.rpm
    pp-sitebuilder-skins-5.0.0-687.10092415.noarch.rpm
    pp-sitebuilder-default-templates-5.0.0-33387.10092415.noarch.rpm

    After that, I had to manually create a new repo file and point in to the plesk 10.0.0 repository for my OS (RHEL5 x86).

    I was THEN able to upgrade plesk to version 10 using the command line interface.
     
  6. ChrisKMEX

    ChrisKMEX New Pleskian

    15
    85%
    Joined:
    Nov 10, 2010
    Messages:
    9
    Likes Received:
    0
    Thanks for your help !
     
  7. eilko

    eilko Regular Pleskian

    28
    73%
    Joined:
    Aug 1, 2001
    Messages:
    468
    Likes Received:
    4
    Location:
    Enschede, Netherlands
    make sure you use the latest version of the autoinstaller! I used an older version and got the same problems, new version solved it.
     
  8. Freddie Bleiweiss

    Freddie Bleiweiss Basic Pleskian

    25
     
    Joined:
    May 10, 2009
    Messages:
    30
    Likes Received:
    0
    What ia the URL or location you downloaded from?
     
  9. deeplist

    deeplist Guest

    0
     
    I have uploaded the three RPM packages that you need in order to get the upgrade to begin. Log into your server via SSH and then do the following commands:

    wget http://deckerservices.com/plesk/rpm/pp-sitebuilder-5.0.0-33387.10092415.noarch.rpm
    wget http://deckerservices.com/plesk/rpm/pp-sitebuilder-default-templates-5.0.0-33387.10092415.noarch.rpm
    wget http://deckerservices.com/plesk/rpm/pp-sitebuilder-skins-5.0.0-687.10092415.noarch.rpm

    rpm -ivh --nodeps pp*
    /usr/local/psa/admin/bin/autoinstaller


    You should now be able to run the plesk update. Upgrade to 10.0.0 first and then upon completion run the updater utility again and go to 10.0.1. I tried to upgrade to 10.0.1 first and skip 10.0.0 and received more errors.
     
  10. Freddie Bleiweiss

    Freddie Bleiweiss Basic Pleskian

    25
     
    Joined:
    May 10, 2009
    Messages:
    30
    Likes Received:
    0
    Thank you!!! That solved my problem.
     
  11. deeplist

    deeplist Guest

    0
     
    You're welcome.
     
Loading...