• The new Python extension is now available. It allows customers to deploy and manage WSGI-based Python applications on their websites directly from Plesk.
  • Debian 11 has reached its end-of-life (vendor EOL date - August 31, 2026). Plesk Obsidian 18.0.81 is the last release to support it.
    If you are running Plesk Obsidian on Debian 11, we recommend you upgrade those servers to Debian 12 using our dist-upgrade tool.
  • We plan to deprecate and remove the support for XML RPC protocol versions earlier than 1.6.9.1 in Plesk Obsidian 18.0.82. We strongly recommend that you update all existing integrations using earlier versions of the XML RPC protocol to comply with the version 1.6.9.1 specification.

CentOS 7.2 and Plesk 12.5 problems

matt001

New Pleskian
Hi

I have just done a fresh install of CentOS 7.2 and Plesk 12.5 everything was working fine, created a few hosting plans and now everytime I restart the vps server and it starts up I get the following errors

[FAILED] Failed to start Startup Script for nginx service

[FAILED] Failed to start the PHP 7.2 FastCGI Process Manager

How do I fix this
 
Any additional detail from logs? From /var/log/nginx/error.log at least?
 
Hi there,

it´s a systemD with Plesk 12.5 and nginx and presumably Virtuozzo 7 problem.

My workaround:
1) edit: /usr/lib/systemd/system/nginx.service
2) edit line 3 and add line 4:
After=network-online.target remote-fs.target nss-lookup.target
Wants=network-online.target

Line 1 to 4 looks like:

[Unit]
Description=Startup script for nginx service
After=network-online.target remote-fs.target nss-lookup.target
Wants=network-online.target


nginx should start now after reboot. I hope Odin can fix this in a update.
 
Back
Top