• Debian 11 has reached its end-of-life (vendor EOL date - August 31, 2026). Plesk Obsidian 18.0.81 is the last release to support it.
    If you are running Plesk Obsidian on Debian 11, we recommend you upgrade those servers to Debian 12 using our dist-upgrade tool.
  • We plan to deprecate and remove the support for XML RPC protocol versions earlier than 1.6.9.1 in Plesk Obsidian 18.0.82. We strongly recommend that you update all existing integrations using earlier versions of the XML RPC protocol to comply with the version 1.6.9.1 specification.

Connecting to FTP repository fails with 550 SSL/TLS required on the control channel

chris_cross

New Pleskian
Hi,

we run several Plesk 11 servers and upgraded some of them to Plesk 12. After the upgrade we got problems (on all Plesk 12 machines) to connect to our backup server via TLS.
The backup server is a ProFTP that did his job pretty well so far. The interface throws the unspecific error:

Transport error: unable to list directory: Curl error: Login denied

I simulated the handshake with:
Code:
curl -v -k --ftp-ssl *IP*:2121 --user user:password --upload-file /usr/local/psa/PMM/tmp/testfile

and got:

Code:
* Connected to **** (*IP*) port 2121 (#0)
* Server auth using Basic with user 'user'
> PUT /testfile HTTP/1.1
> Authorization: Basic 
> User-Agent: curl/7.26.0
> Host: *IP*:2121
> Accept: */*
> Content-Length: 0
> Expect: 100-continue
> 
* additional stuff not fine transfer.c:1037: 0 0
{ [data not shown]
* Increasing bytecount by 84 from hbuflen
220 ProFTPD 1.3.4d Server (*HOSTNAME* FTP Server) [::ffff:*IP*]
550 SSL/TLS required on the control channel
550 SSL/TLS required on the control channel
550 SSL/TLS required on the control channel
...

It seems that Plesk does not communicate to the ftp server properly.

Some of the relevant settings of the ftp server:

The ftp server running behind a firewall and listening to port 21. External port is forwarded to port 21 correctly. (connection with ftp program works flawlessly)

IdentLookups off
UseReverseDNS off
PassivePorts 2122 2222

<IfModule mod_tls.c>
TLSEngine on
TLSProtocol SSLv23
TLSOptions NoCertRequest
TLSRSACertificateFile /etc/ssl/freenas/proftpd/proftpd.crt
TLSRSACertificateKeyFile /etc/ssl/freenas/proftpd/proftpd.key
TLSVerifyClient off
TLSRequired ctrl
</IfModule>

Is there a solution (or upcoming bug fix) for this problem? Any idea?

Thanks in advance
 
Back
Top