• Debian 11 has reached its end-of-life (vendor EOL date - August 31, 2026). Plesk Obsidian 18.0.81 is the last release to support it.
    If you are running Plesk Obsidian on Debian 11, we recommend you upgrade those servers to Debian 12 using our dist-upgrade tool.
  • We plan to deprecate and remove the support for XML RPC protocol versions earlier than 1.6.9.1 in Plesk Obsidian 18.0.82. We strongly recommend that you update all existing integrations using earlier versions of the XML RPC protocol to comply with the version 1.6.9.1 specification.

couldn't connect to server to sync license

saatchi

Basic Pleskian
Hello,

When I try to upgrade Plesk to version 10 I get this error:

Exchanging information with licensing server.
File downloading PSA_10.0.1/plesk_getkeyinfo.sh: 29%..67%..100% was finished.
XMLRPC remote call failed: HTTP error #-1 occurred
Fatal Error: connect operation failed (Connection timed out)
Error: Failed to connect to the licensing server.

Continuing with the upgrade without having an appropriate product license key
will result in the installation of a default license key with limited
functionality. Administrators are advised to first acquire the appropriate
license key before continuing with the product upgrade.

I purchased this new version 1 weak ago and it's valid. When I try "Retrieve Keys" in the panel, I get this error:

Key Update Status
couldn't connect to server

Is there any port that I've to open it to sync license with the server?

OS: CentOS 5
Plesk 9.5.3

Regards,
 
Hello,
So I solve it and write it here for others.

Plesk license server connection is using port 5224 and if it's deny it will not accept your license completely. To check that this port is open or not, you can check with this command:

curl -k https://ka.parallels.com:5224

if this return values (not error in connection), your connection is healthy.
 
Last edited:
Back
Top