• Debian 11 has reached its end-of-life (vendor EOL date - August 31, 2026). Plesk Obsidian 18.0.81 is the last release to support it.
    If you are running Plesk Obsidian on Debian 11, we recommend you upgrade those servers to Debian 12 using our dist-upgrade tool.
  • We plan to deprecate and remove the support for XML RPC protocol versions earlier than 1.6.9.1 in Plesk Obsidian 18.0.82. We strongly recommend that you update all existing integrations using earlier versions of the XML RPC protocol to comply with the version 1.6.9.1 specification.

Issue Critical Error cPanel to Plesk Migration

larryinfl

New Pleskian
Hello,

I'm trying to move a cpanel account to a plesk server.

In plesk, under Extensions, I am selecting the Plesk Migrator tool. It says version 2.1.4

In the Migrator settings I select cpanel server, enter the cpanel source server ip and enter the cpanel server root login credentials.

It then trys to start the process for about 20 seconds and then gives me the error below.

Does anyone have any insight how to correct this error?

==

That is a critical error, migration was stopped.
[2016-10-18 23:48:25][INFO] START: Check connections
[2016-10-18 23:48:26][INFO] FINISH: Check connections
[2016-10-18 23:48:26][INFO] Deploy migration agent to '**IP.HIDDEN**'
[2016-10-18 23:48:28][INFO] Create source panel dump XML
[2016-10-18 23:48:32][ERROR] Failed to perform action: Fetch data from source cPanel
Cause: Error creating migration dump: Command execution failed on the source server 'cpanel' (**IP.HIDDEN**) with non-zero exit code.
command: cd /tmp/pmm_agent; /usr/bin/perl cPanel9.pl --dump-all --configuration-only --server -v 5 > dump.log 2>&1
exit code: 2
stdout:
stderr: stdin: is not a tty

That is a critical error, migration was stopped.
 
Hello! Could you please confirm, that you specify exactly the root user (user with UID=0) and password for source cPanel server when configuring migration?
 
Looks like source agent does not work properly. Could you please check your migration session directory (/usr/local/psa/var/modules/panel-migrator/sessions/YYYYMMDDHHIISS/) on target server? There should be a sub directory pmm-agent.YYYY.MM.DD.HH.II.SS with source agent log files. Could you please send this logs to me via private conversation?
 
Hello Aleksey,

Any chance you have been able to look at this? I got a Plesk VPS to host my main website only and I'm unable to use it at all right now because I can not move it over.

I could move the site itself easily doing it manually. The main reason I need to use the transfer feature is to move about 1 GB of email in my main email account. So if there is a way to move the email account I would not need to use the transfer tool.

Thanks!
 
Back
Top