1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Debian 5 php 5.3.5 upgrade to Plesk 10.1.1 issue

Discussion in 'Plesk 10.x for Linux Issues, Fixes, How-To' started by kevin anderson, Jan 26, 2011.

  1. kevin anderson

    kevin anderson Guest

    0
     
    The Plesk autoinstaller is not allowing me to upgrade my debian Lenny to 10.1.1 from 10.0.1 due to the below error:

    Code:
    The following packages have unmet dependencies:
      php5-ioncube-loader: Depends: php5 (< 5.3.0) but 5.3.5-0.dotdeb.0 is to be installed
    I thought Plesk was supposed to work independently of the PHP version, so I assume this is a bug in Plesk's Debian package? The php5-ioncube-loader is a parallels provided package, that is downloaded from autoinstall.plesk.com
     
  2. nucknuck

    nucknuck Basic Pleskian

    21
    23%
    Joined:
    Jan 25, 2011
    Messages:
    66
    Likes Received:
    1
  3. kevin anderson

    kevin anderson Guest

    0
     
    Any updates on this issue? I see that fixes were provided for the redhat derivatives, but not the debian/ubuntu distros?
     
  4. kevin anderson

    kevin anderson Guest

    0
     
    aptitude full-upgrade
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    Reading extended state information
    Initializing package states... Done
    The following packages are BROKEN:
    php5-ioncube-loader
    The following packages will be upgraded:
    php5
    1 packages upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
    Need to get 1060B of archives. After unpacking 0B will be used.
    The following packages have unmet dependencies:
    php5-ioncube-loader: Depends: php5 (< 5.3.0) but 5.3.5-0.dotdeb.0 is to be installed.
    The following actions will resolve these dependencies:

    Downgrade the following packages:
    php5 [5.2.17-0.dotdeb.0 (oldstable, now) -> 5.2.6.dfsg.1-1+lenny9 (oldstable, oldstable)]

    Score is 20

    Accept this solution? [Y/n/q/?]
     
  5. nucknuck

    nucknuck Basic Pleskian

    21
    23%
    Joined:
    Jan 25, 2011
    Messages:
    66
    Likes Received:
    1
    i don´t think there will come a fix.
    parallels don´t want us to use php 5.3.x
     
  6. IgorG

    IgorG Forums Analyst Staff Member

    49
    24%
    Joined:
    Oct 27, 2009
    Messages:
    24,572
    Likes Received:
    1,243
    Location:
    Novosibirsk, Russia
    Once again. Parallels does not provide PHP for hosting. It is provided by OS vendor. Contact Debian, Suse, RH, etc. if you want to use PHP 5.3.x or compile it by yourself from source.
     
  7. nucknuck

    nucknuck Basic Pleskian

    21
    23%
    Joined:
    Jan 25, 2011
    Messages:
    66
    Likes Received:
    1
    ok, just for my understanding:


    setup environment is a debian lenny 64bit minimal
    at apt sources list there is only one extra source for php 5.3
    then i use the autoinstaller and get this message that the dependencies of the ioncube loader are unmet.

    in fact i´am able to install and configurate a working php 5.3.5 with useable ioncube loader.

    and now you tell me that it is an issue of the system and php if the plesk autoinstaller behaves like this?

    a) unmet dependencies with only addong php 5.3.x source
    b) unmet dependencies with previous installed php 5.3.5 and manually install ioncube loader and edited php.ini to link to the new ioncube loader

    so don´t write only "once again ..." - i´m sorry that i bought a product and that i have to ask some things for using it in the best way ...
     
  8. IgorG

    IgorG Forums Analyst Staff Member

    49
    24%
    Joined:
    Oct 27, 2009
    Messages:
    24,572
    Likes Received:
    1,243
    Location:
    Novosibirsk, Russia
    Did you try install Plesk to debian lenny 64bit minimal environment without this "only one extra source for php 5.3" and update PHP later after success Plesk installation?
     
  9. kevin anderson

    kevin anderson Guest

    0
     
    Igor,

    This does not work. The issue at hand, is that php5-ioncube-loader has improper dependencies set. This is a package that is provided through the packages.parallels.com source, not the standard debian sources. This was not an issue until Plesk 10.1.1 I believe. Plesk 9.5.4 or even Plesk 10.0.0 did not have this dependency, as I was using php 5.3 for months without issues before upgrading to Plesk 10.1.1

     
  10. IgorG

    IgorG Forums Analyst Staff Member

    49
    24%
    Joined:
    Oct 27, 2009
    Messages:
    24,572
    Likes Received:
    1,243
    Location:
    Novosibirsk, Russia
  11. kevin anderson

    kevin anderson Guest

    0
     
    Igor,

    Is there an i386 version of that file? yes, I have tried backing out of the dot deb source and downgrading php, and re-attempting to upgrade. It still gives the same dependency issue.

    There does not seem to be an i386 version of your version of the installer, and it is a different version than what is provided for the download provided at http://www.parallels.com/download/plesk10 . Do you have an i386 version?
     
  12. IgorG

    IgorG Forums Analyst Staff Member

    49
    24%
    Joined:
    Oct 27, 2009
    Messages:
    24,572
    Likes Received:
    1,243
    Location:
    Novosibirsk, Russia
    First link is autoinstaller for i386 and second link is autounstaller for x86_64 platform.
     
  13. kevin anderson

    kevin anderson Guest

    0
     
    I attempted as you suggested, still having issues.

    As previously stated, this issue stems from the dependencies required in the .deb file. Note the below command line output.

    as you can see, the Depends list:
    Depends: libc6 (>= 2.7-1), php5 (>= 5.2.0), php5 (<< 5.3.0)

    This is in effect keeping php 5.3 from being installed properly in an environment with Plesk on debian 5.

    Debian 6, fyi, defaults to php 5.3.
     
  14. IgorG

    IgorG Forums Analyst Staff Member

    49
    24%
    Joined:
    Oct 27, 2009
    Messages:
    24,572
    Likes Received:
    1,243
    Location:
    Novosibirsk, Russia
Loading...