1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice

DNS - redirecting mail

Discussion in 'Plesk for Linux - 8.x and Older' started by dfutura, Jul 22, 2005.

  1. dfutura

    dfutura Basic Pleskian

    23
    57%
    Joined:
    May 10, 2004
    Messages:
    30
    Likes Received:
    0
    I want to redirect mail to another mailserver and i am configuring dns but it dont work, these are dns zones:

    hercesa.com. NS ns.hercesa.com.
    ns.hercesa.com. A 62.151.22.112
    hercesa.com. A 62.151.22.112
    mail.hercesa.com. A 222.222.222.222
    mail.hercesa.com. MX (10) hercesa.com.
    62.151.22.112 / 24 PTR hercesa.com.
     
  2. jamesyeeoc

    jamesyeeoc Guest

    0
     
    The HOST should be hercesa.com. The value should be mail.hercesa.com

    hercesa.com. MX (10) mail.hercesa.com.
     
  3. dfutura

    dfutura Basic Pleskian

    23
    57%
    Joined:
    May 10, 2004
    Messages:
    30
    Likes Received:
    0
    I have made the chage but it dont work. The problem is only inside the plesk server. all the domains of the server cant send messages to this domain. The external dns in the isp are ok

    these are dns zones inside server:

    hercesa.com. NS ns.hercesa.com.
    ns.hercesa.com. A 62.151.22.112
    hercesa.com. A 62.151.22.112
    mail.hercesa.com. A 222.222.222.222
    hercesa.com. MX (10) mail.hercesa.com.
    62.151.22.112 / 24 PTR hercesa.com.
     
  4. poke

    poke Guest

    0
     
    looks fine to me....
     
  5. jamesyeeoc

    jamesyeeoc Guest

    0
     
    Do the messages get bounced back? Probably go to nowhere....(actually in mail queue on this local server).

    Check the contents of the /var/qmail/control/rcpthosts file, it should contain the domain names of all the domains hosted on this server, one name per line.
    But not the name hercesa.com since that MX is being hosted outside this server

    /var/qmail/control/smtproutes should contain the local server domain name which is associated with 127.0.0.1 and any external domain names if the MX is hosted outside this server:

    smtproutes file:
    mainserverdomain.com:127.0.0.1:25
    hercesa.com:222.222.222.222:25
     
  6. sieb@

    sieb@ Guest

    0
     
    If mail for a domain is being handled by a server other that the local PSA server, the domain in question needs to be removed from rcpthosts and virtualdomains files. You may have to create the smtproutes file with the domain:IP of the new server. Qmail doesn't reference the OS's hosts file.

    Otherwise Qmail will see the domain in its lists and keep trying to route locally instead of passing the mail to the remote queue.
     
  7. dfutura

    dfutura Basic Pleskian

    23
    57%
    Joined:
    May 10, 2004
    Messages:
    30
    Likes Received:
    0
    Thx.
    Now the messages can be sent.
     
  8. dfutura

    dfutura Basic Pleskian

    23
    57%
    Joined:
    May 10, 2004
    Messages:
    30
    Likes Received:
    0
    i have an other prblem now. When i send a message to some domain of the server from another server, the bounced back:

    The original message was received at Sat, 23 Jul 2005 21:46:50 +0200
    from localhost.localdomain [127.0.0.1]

    ----- The following addresses had permanent fatal errors -----
    <sgallego@dfutura.net>
    (reason: 553 sorry, that domain isn't in my list of allowed rcpthosts; no valid
    cert for gatewaying (#5.7.1))

    ----- Transcript of session follows -----
    ... while talking to mx.dfutura.net.:
    >>> DATA
    <<< 553 sorry, that domain isn't in my list of allowed rcpthosts; no valid cert for
    gatewaying (#5.7.1)
    550 5.1.1 <sgallego@dfutura.net>... User unknown
    <<< 503 RCPT first (#5.5.1)

    The domain dfutura.net is in rcpthosts
    ¿why qmail said that it isnt?
     
  9. jamesyeeoc

    jamesyeeoc Guest

    0
     
    Looks like you are trying to send using SSL and the certificate can't be found. Try turning off SSL secure connection in your mail client (Outlook?) and see if the error still occurs.
     
  10. dfutura

    dfutura Basic Pleskian

    23
    57%
    Joined:
    May 10, 2004
    Messages:
    30
    Likes Received:
    0
    i am trying to send with webmail and hotmail.
     
  11. dfutura

    dfutura Basic Pleskian

    23
    57%
    Joined:
    May 10, 2004
    Messages:
    30
    Likes Received:
    0
  12. jamesyeeoc

    jamesyeeoc Guest

    0
     
    Hmm, I had to unblock your IP (part of my anti-spam netblock, Spain and all)

    Do a 'cat -A /var/qmail/control/rcpthosts' and post the results here.

    Also for the files: locals, me, smtproutes, and virtualdomains (all in the same directory).
     
  13. dfutura

    dfutura Basic Pleskian

    23
    57%
    Joined:
    May 10, 2004
    Messages:
    30
    Likes Received:
    0
    rcpthosts ->

    likeu.es^M$
    lucacom.es^M$
    ejsiabogados.com^M$
    lanzapat.com^M$
    tienda.onilusion.com^M$
    easymail.dfutura.com^M$
    ngpautosalon.com^M$
    ideasgc.com^M$
    gaa.es^M$
    dfutura.net^M$
    adelaherran.com^M$
    dfutura.com^M$
    echesscafe.com^M$
    equalsa.com^M$
    radiacentro.com^M$
    rnavarra.com^M$
    fincaandaluza.com^M$
    infocarcomunicacion.com^M$
    relievesdgr.com^M$

    virtualdomains->

    likeu.es:6^M$
    lucacom.es:4^M$
    ejsiabogados.com:5^M$
    lanzapat.com:14^M$
    tienda.onilusion.com:30^M$
    easymail.dfutura.com:16^M$
    ngpautosalon.com:17^M$
    ideasgc.com:18^M$
    gaa.es:31^M$
    dfutura.net:33^M$
    adelaherran.com:35^M$
    dfutura.com:36^M$
    echesscafe.com:37^M$
    equalsa.com:38^M$
    radiacentro.com:39^M$
    rnavarra.com:40^M$
    fincaandaluza.com:41^M$
    infocarcomunicacion.com:42^M$
    relievesdgr.com:43^M$

    me ->
    onilusion.com

    locals >
    localhost$

    I have deleted virtualdomains because i thought that culd be the problem
     
  14. jamesyeeoc

    jamesyeeoc Guest

    0
     
    You need the virtualdomains file!!! Replace it!!!

    What looks like the problem is, is that you may be editing the files under Windows and uploading them to the server.

    That would explain all the ^M characters in the files.

    When you edit files under Windows, normal Win editors will put LFCR on the end of lines. Linux likes to have just LF without the CR.

    Option 1: Use a different editor which can be set to Linux/Unix mode (I use NoteTab Lite, but there are others)

    Option 2: Recreate the files from scratch using the Linux editors (such as nano, pico, vi, emacs)

    Option 3: Use the linux utiltiy 'dos2unix' on the text files to remove the ^M characters.
    For each file, do 'dos2unix filename' and it will remove the ^M characters.


    Then restart Qmail (or everything)

    Simplest to do Option 3
     
  15. dfutura

    dfutura Basic Pleskian

    23
    57%
    Joined:
    May 10, 2004
    Messages:
    30
    Likes Received:
    0
    that was the problem, now it works.

    i must have the same problem with vhost.conf to enable register_globals

    thanks!!!!


    :)
     
Loading...