1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Domain hosting Settings: PHP support - does not work

Discussion in 'Plesk 11.x for Linux' started by Michael Wa., Oct 11, 2012.

  1. Michael Wa.

    Michael Wa. Basic Pleskian

    20
    57%
    Joined:
    Feb 12, 2010
    Messages:
    31
    Likes Received:
    0
    Hi there,

    I've got the problem that I'm not able to change the PHP support (run as CGI application) zu FastCGI.
    The dropdown only shows PHP support (run as CGI application)

    (I migrated from Plesk 10 to 11)
    On some other Domains in Plesk it's possible to switch to FastCGI or to Apache Module.

    Any ideas how I can switch from CGI to FastCGI ??
    I can change it in the "Service Plan" settings however this does not work for the mentioned domains either.

    thanks!
     
  2. IgorG

    IgorG Forums Analyst Staff Member

    49
    24%
    Joined:
    Oct 27, 2009
    Messages:
    24,572
    Likes Received:
    1,243
    Location:
    Novosibirsk, Russia
    Are you sure that you have corresponding permissions in subscription?
     
  3. Michael Wa.

    Michael Wa. Basic Pleskian

    20
    57%
    Joined:
    Feb 12, 2010
    Messages:
    31
    Likes Received:
    0
    hmmm I'll check this. thanks.

    Which permission setting does affect the php mode?

    Even if I select the "Unlimited" service plan, I can not chnage from CGI.
     
    Last edited: Oct 11, 2012
  4. Michael Wa.

    Michael Wa. Basic Pleskian

    20
    57%
    Joined:
    Feb 12, 2010
    Messages:
    31
    Likes Received:
    0
    sorry I checked all permission options & unlimited and it still does not work.
    Any other ideas?
     
  5. abdi

    abdi Platinum Pleskian

    31
    18%
    Joined:
    May 14, 2006
    Messages:
    2,913
    Likes Received:
    60
    Make sure once you changed the corresponding service plan, you clicked sync. ALSO ensure the subscription in question is not locked to deny the sync changes.
     
  6. Michael Wa.

    Michael Wa. Basic Pleskian

    20
    57%
    Joined:
    Feb 12, 2010
    Messages:
    31
    Likes Received:
    0
    everything is synced/green.

    Could the file permissions (file owner rights...) affect these setting?
     
  7. EugeneKazakov

    EugeneKazakov Basic Pleskian Staff Member

    19
     
    Joined:
    Aug 22, 2012
    Messages:
    99
    Likes Received:
    7
  8. Michael Wa.

    Michael Wa. Basic Pleskian

    20
    57%
    Joined:
    Feb 12, 2010
    Messages:
    31
    Likes Received:
    0
    My default settings are as follows.

    ;; The section describes allowed hosting options
    [hosting]
    ;php = any
    ;php_handler_type = fastcgi
    ;python = off
    ;perl = off
    ;fastcgi = any
    ;miva = off
    ;ssi = any
    ;ssl = on
    ;shell = /usr/local/psa/bin/chrootsh
    ;asp = any
    ;php_safe_mode = on
    ;coldfusion = off

    Do you think commenting IN the fastcgi lines may help?
     
  9. abdi

    abdi Platinum Pleskian

    31
    18%
    Joined:
    May 14, 2006
    Messages:
    2,913
    Likes Received:
    60
    PHP Version

    Please find attached the option where you change the version of php. Its under service plans -> customization. You could do the same with the subscription it self.

    Please let me know if that answers your question or not ...
     

    Attached Files:

  10. Michael Wa.

    Michael Wa. Basic Pleskian

    20
    57%
    Joined:
    Feb 12, 2010
    Messages:
    31
    Likes Received:
    0
    Hi Abdi,

    yes that's where I try t change the settings. However my drop down only allows me to select "CGI application" instead of "fast CGI"
     

    Attached Files:

  11. EugeneKazakov

    EugeneKazakov Basic Pleskian Staff Member

    19
     
    Joined:
    Aug 22, 2012
    Messages:
    99
    Likes Received:
    7
    Drop down in service plan does not check capabilities of server - all handlers are displayed here.
    Drop down in subscription checks what is realy available.

    Looks like you have not installed components required by fastCGI mode.
    Check it manually:
    /usr/local/psa/admin/bin/packagemng -l | grep psa-mod-fcgid-configurator
    apachectl -M | grep fcgi

    Possibly you should install it in Autoinstaller > Plesk hosting features > Apache mod_fcgid module
    Or only enable in Plesk > Tools & Settings > Apache Modules
     
  12. Michael Wa.

    Michael Wa. Basic Pleskian

    20
    57%
    Joined:
    Feb 12, 2010
    Messages:
    31
    Likes Received:
    0
    sorry. has been a good point. however fcgi module is active...

     

    Attached Files:

  13. itmnetcom

    itmnetcom Basic Pleskian

    14
    80%
    Joined:
    Aug 1, 2011
    Messages:
    37
    Likes Received:
    0
    Plesk 11 and Nginx

    I disabled NGINX because i was getting Gateway 400 errors, and now it has removed the PHP Support dropdown, no longer shows or runs. So all my sites are down.

    I have searched everywhere and could not found how to enable PHP Support. PHP -v shows it installed..

    Any ideas?
     
Loading...