• Debian 11 has reached its end-of-life (vendor EOL date - August 31, 2026). Plesk Obsidian 18.0.81 is the last release to support it.
    If you are running Plesk Obsidian on Debian 11, we recommend you upgrade those servers to Debian 12 using our dist-upgrade tool.
  • We plan to deprecate and remove the support for XML RPC protocol versions earlier than 1.6.9.1 in Plesk Obsidian 18.0.82. We strongly recommend that you update all existing integrations using earlier versions of the XML RPC protocol to comply with the version 1.6.9.1 specification.

Resolved ERROR 1102 (42000) at line 20: Incorrect database name ''

LarsenD

Regular Pleskian
This is just a bug report. No help needed as it doesn´t seem to cause problems.

When I update servers via CLI autoinstaller, I sometimes (or on some servers) get this error message:
Code:
Trying to start psa...
Stopping psa... Stopping Plesk engine pool manager: sw-engine-fpm.
done
===> Installing phpMyAdmin
Trying to create pmadb... ERROR 1102 (42000) at line 20: Incorrect database name ''

Afaik, no server has this DB.
 
Not all "ERROR" in your log - file might cause issues/problems... it might as well only point to some misconfigurations, or missing features from a complete basic Plesk installation.
 
Found the reason and fix myself.

Plesk uses the old phpMyAdmin config from "/opt/psa/admin/htdocs/domains/databases/phpMyAdmin/libraries/config.default.php". Probably due to a bug in an old version of Plesk, this did not contain the database name, but this:
Code:
$cfg['Servers'][$i]['pmadb'] = $GLOBALS['db_host'] != 'localhost' ? '' : '';

When it should contain something like this:
Code:
$cfg['Servers'][$i]['pmadb'] = 'phpmyadmin__lL4vGxF8vvH';

Check this by executing:
Code:
grep pmadb /opt/psa/admin/htdocs/domains/databases/phpMyAdmin/libraries/config.default.php

Solution:
- Delete all phpMyAdmin databases
- rm -f /opt/psa/admin/htdocs/domains/databases/phpMyAdmin/libraries/config.default.php
- Upgrade Plesk
 
Back
Top