1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

ERROR: PleskFatalException

Discussion in 'Plesk for Linux - 8.x and Older' started by ashley1, Jan 6, 2008.

  1. ashley1

    ashley1 Guest

    0
     
    Hi, i bought a self managed server with plesk license, while installing it, i started mysql server , however when i try to get into plesk it gives me the following error..

    ERROR: PleskFatalException
    Unable to connect to database: saved admin password is incorrect.

    0: /usr/local/psa/admin/plib/common_func.php3:156
    psaerror(string 'Unable to connect to database: saved admin password is incorrect.')
    1: /usr/local/psa/admin/auto_prepend/auth.php3:90

    i changed the mysql password but it keeps giving the same error...
    can any1 help please,
    thank you
     
  2. Bender

    Bender Guest

    0
     
  3. ashley1

    ashley1 Guest

    0
     
    thank you for your help Bender, i followed all steps in http://kb.swsoft.com/en/346

    i tried to restart plesk but it gives me this error "ERROR 1045: Access denied for user: 'admin@localhost' (Using password: YES)" so all i did was :
    /usr/local/psa/admin/sbin/ch_admin_passwd
    # export PSA_PASSWORD='NEW_PASSWORD' ; /usr/local/psa/admin/sbin/ch_admin_passwd; unset PSA_PASSWORD

    Load MySQL with the 'skip-grant-tables' option by adding skip-grant-tables into [mysqld] section of the /etc/my.cnf file
    Restart MySQL
    Put the new password into /etc/psa/.psa.shadow file.
    Repair password with the command line below:
    # /usr/bin/mysql -D mysql -e"update user set password=PASSWORD('`cat /etc/psa/.psa.shadow`') where User='admin';"
    Remove skip-grant-tables option from /etc/my.cnf
    Restart MySQL.

    and it worked fine but as soon as i remove skip-grant-tables option from /etc/my.cnf skip , i get the same error again , does any1 has a solution for this, and thank you again
     
  4. JunyaS

    JunyaS Guest

    0
     
    Hi. I've encountered the same problem after I imported a mysqldump file from another server (non-Plesk machine).
    In my case, the imported database had a super user called 'root' with a valid password, so I connected to the database by "mysql -u root -p" and manually created another super user 'admin' to be used by Plesk.
     
Loading...