1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Error running cron

Discussion in 'Plesk for Linux - 8.x and Older' started by StuartS, May 16, 2008.

  1. StuartS

    StuartS Guest

    0
     
    I am getting the following error message after running a php script using a cron job from my VPS.


    --07:05:01-- http://www.examsolutions.co.uk/tuition/expiring_ad.php
    => `expiring_ad.php'
    Resolving www.examsolutions.co.uk... 212.241.218.66
    Connecting to www.examsolutions.co.uk|212.241.218.66|:80... connected.
    HTTP request sent, awaiting response... 200 OK
    Length: 258 [text/html]
    expiring_ad.php: Permission denied

    Cannot write to `expiring_ad.php' (Permission denied).

    Can anyone tell me what to do to stop this.

    Many thanks in advance
     
  2. tekmaster

    tekmaster Guest

    0
     
    Fix?

    Hi, you probably just have to change the file permissions to 777 or rwxrwxrwx...

    To do this, either go to the parent folder in SSH and do:

    chown -hR [user]: psacln [folder]
    chmod -R 755 [folder]

    or if that fails

    chown -hR [user]: psacln [folder]
    chmod -R 777 [folder]

    (remove the space after the : - it is there to prevent smiley)

    or from Plesk file manager change permissions on the folder to allow read, write and execute to all...
     
  3. StuartS

    StuartS Guest

    0
     
    I tried changing the folder and file permissions to 777 but unfortunately I still get the same error.

    Any ideas?

    Thanks in advance
     
Loading...