1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

FastCGI is not working in Plesk 10.4.4 MUI20 running in Ubuntu 10.04

Discussion in 'Plesk 10.x for Linux Issues, Fixes, How-To' started by TuroLate, Mar 15, 2012.

  1. TuroLate

    TuroLate Guest

    0
     
    Hi,

    When I enable FastCGI on any domain in my Plesk server, if I try to run a php file it shows with the error message:

    ------------8<------------

    Internal Server Error
    The server encountered an internal error or misconfiguration and was unable to complete your request.

    Please contact the server administrator to inform of the time the error occurred and of anything you might have done that may have caused the error.

    More information about this error may be available in the server error log.

    Web Server at domain.com

    ------------8<------------

    In the server error log this is the only thing that comes:

    -------------8<-------------

    [Thu Mar 15 15:51:58 2012] [warn] [client xxx.xxx.xxx.xxx] (104)Connection reset by peer: mod_fcgid: error reading data from FastCGI server
    [Thu Mar 15 15:51:58 2012] [error] [client xxx.xxx.xxx.xxx] Premature end of script headers: test.php

    -------------8<-------------

    If I su as the ftp/user/owner of the domain and try to run the cgi_wrapper that Plesk writes in the .conf files for the domain:

    /var/www/cgi-bin/cgi_wrapper/cgi_wrapper < /var/www/vhosts/domain.com/httpdocs/test.php

    It works ok.

    This is what I'm running:

    # lsb_release -a
    No LSB modules are available.
    Distributor ID: Ubuntu
    Description: Ubuntu 10.04.4 LTS
    Release: 10.04
    Codename: lucid

    # cat .autoinstaller/microupdates.xml
    <?xml version="1.0" encoding="UTF-8" standalone="yes" ?>
    <patches>
    <product id="plesk" version="10.4.4" installed-at="20120315T102926">
    <patch version="20" timestamp="" installed-at="20120315T103340" />
    </product>
    </patches>

    Does anyone know of a solution for this issue?

    Thanks in advance.
     
  2. TuroLate

    TuroLate Guest

    0
     
    Anyone?

    Still not working on: 10.4.4 Update #25, last updated at April 10, 2012 06:25 AM
     
  3. TuroLate

    TuroLate Guest

    0
     
    Managed to fix it.

    I fixed it in the end, let's say I'm not impressed with Plesk in general.
     
  4. Sergey L

    Sergey L Golden Pleskian Staff Member

    32
    43%
    Joined:
    Aug 10, 2006
    Messages:
    1,195
    Likes Received:
    30
    So what have you done to fix it? Did you figure out what was wrong?
     
  5. ZopfWare

    ZopfWare Regular Pleskian

    25
    57%
    Joined:
    May 30, 2004
    Messages:
    215
    Likes Received:
    0
    What did you do to fix this issue?
     
Loading...