1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Horde sends redirect.php after login

Discussion in 'Plesk for Linux - 8.x and Older' started by gjmjr, Sep 5, 2006.

  1. gjmjr

    gjmjr Guest

    0
     
    Horde sends redirect.php after login (horde crashes apache)

    I recently installed Plesk 8.0.1 on a new server with a fresh installation of SuSE 10.0. After upgrading apache, php and mysql (security updates, using yast) horde/imp stopped working. After login horde downloads me 'redirect.php' instead of logging in.

    Sounds like some configuration problem but I can't find it. I have uninstalled imp and horde and reinstalled it, but to no avail.

    Does anyone have a suggestion how fix this?
     
  2. gjmjr

    gjmjr Guest

    0
     
    The apache error_log shows:

    [Tue Sep 05 11:39:44 2006] [notice] child pid 2752 exit signal Segmentation fault (11)

    No error is logged in psa-horde.log

    :confused:
     
  3. gjmjr

    gjmjr Guest

    0
     
    Am I the only one with this problem?

    Boy, am I happy with Plesk or what? :(

    Versions of the installed packages are:

    Name : apache2 Relocations: (not relocatable)
    Version : 2.0.54 Vendor: SUSE LINUX Products GmbH, Nuernberg, Germany
    Release : 10.5 Build Date: do 27 jul 2006 15:27:56 CEST

    Name : php5 Relocations: (not relocatable)
    Version : 5.0.4 Vendor: SUSE LINUX Products GmbH, Nuernberg, Germany
    Release : 9.13 Build Date: do 08 jun 2006 18:57:49 CEST

    Name : mysql Relocations: (not relocatable)
    Version : 4.1.13 Vendor: SUSE LINUX Products GmbH, Nuernberg, Germany
    Release : 3.6 Build Date: do 08 jun 2006 15:28:46 CEST
     
  4. NightStorm

    NightStorm Guest

    0
     
    It's a long-shot, but have you tried a force reinstall of the Horde rpm?
    rpm -Uhv --force <rpm>
    I'm not betting that it will for sure fix the problem, but it would be one less thing on the list of "have you checked...?"
    Also, when you check the ownership and permissions of redirect.php, is it still -rw-r--r-- root:root?
     
  5. gjmjr

    gjmjr Guest

    0
     
    Thanks for you reply NightStorm.

    Yes, I've reinstalled horde and imp, and yes, the files is still 644 root:root.

    Of course nothing from horde/imp has been touched by updating Apache/PHP/MySQL.

    Looks like a conflict from the new server software with Horde or the other way around.

    I read so many problems with the webmail component of Plesk in this forum. Is Horde so buggy/difficult to implement?
     
  6. gjmjr

    gjmjr Guest

    0
     
    Upgraded to:

    Name : apache2 Relocations: (not relocatable)
    Version : 2.0.54 Vendor: SUSE LINUX Products GmbH, Nuernberg, Germany
    Release : 10.8 Build Date: wo 30 aug 2006 17:29:24 CEST


    Still apache crashes when logging in to horde..
     
  7. jamxUK

    jamxUK Guest

    0
     
    Do you have localhost in /etc/hosts?

    I've had numerous problems with horde and the fix was adding localhost to the end of /etc/hosts.

    (Fedora core 3 / 4)

    Regards.

    Jay.
     
  8. gjmjr

    gjmjr Guest

    0
     
    I've tried several adjustments to /etc/hosts but no results:

    127.0.0.1 localhost localhost.mydomain.cxm

    # special IPv6 addresses
    # ::1 localhost ipv6-localhost ipv6-loopback

    #fe00::0 ipv6-localnet

    #ff00::0 ipv6-mcastprefix
    #ff02::1 ipv6-allnodes
    #ff02::2 ipv6-allrouters
    #ff02::3 ipv6-allhosts

    99.99.99.99 myhost.mydomain.cxm myhost
    10.0.0.99 myhost.mydomain.cxm
     
  9. jamxUK

    jamxUK Guest

    0
     
    Have you tried re-installing / updating the IMAP rpm's (especially php-imap)?
     
  10. gjmjr

    gjmjr Guest

    0
     
    Just tried to reinstall php5-imap. No changes.

    Installed packages are:

    php5-dom-5.0.4-9
    php5-iconv-5.0.4-9
    php5-zlib-5.0.4-9
    psa-php5-configurator-1.0.0-suse10.0.build80060718.13
    apache2-mod_php5-5.0.4-9.13
    php5-gd-5.0.4-9.13
    php5-imap-5.0.4-9
    php5-ctype-5.0.4-9
    php5-gettext-5.0.4-9
    php5-curl-5.0.4-9
    php5-mcrypt-5.0.4-9
    php5-mysql-5.0.4-9
    php5-5.0.4-9.13
    php5-mbstring-5.0.4-9.13

    Note that this is a clean Plesk 8.0.1 on a clean SuSE 10.0 server. I only updated using yast after installation, so nothing other than apache2/php5/mysql has been touched.

    At the moment my only option is to deny clients access to webmail.
     
  11. jamxUK

    jamxUK Guest

    0
     
    Personally I don't update plesk systems using the distro update tools as it's likley to break everything. As I'm using fedora, I use Atomoic Rocket Turtle RPM's as they are plesk compatable.

    You need to see if there are any compatable SuSE RPM's otherwise sure rpm to roll back to the last stable plesk rpm's for PHP, apache or mysql.

    On an aside, I use php5 on one of my plesk boxes but compiled it from source as to leave php4 alone. I therefore run the two together, allowing php4 to run things like psa and horde.
     
  12. gjmjr

    gjmjr Guest

    0
     
    I have never found any guidelines for updating systems running Plesk. So actually what you're saying is that you are at the mercy of SWsoft for applying critical security patches for server software? And -still- you sleep well at night? ;)
     
  13. jamxUK

    jamxUK Guest

    0
     
    Technically yes, but hence I use Atomic Rocket Turtle RPM's as they stay up to date. (I don't think they have SuSE rpm's)

    And for the record, I sleep great at night, and yes I do sleep with my head in the sand. ;)
     
Loading...