1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

index.html required in Url

Discussion in 'Plesk for Linux - 8.x and Older' started by Deputy, Aug 13, 2006.

  1. Deputy

    Deputy Guest

    0
     
    index.html required in Url why?

    Hi I am testing plesk 8.01 on a centos 4,3
    and have setup one domain.
    But I have to include index.html. www.mydomain.com/index.html in the Url ?
    www.mydomain.com brings up the apache test page
    Do I have to configure this in plesk
    Or is this a bug is there a patch or a file I should edit.

    Thanks:confused:
     
  2. Deputy

    Deputy Guest

    0
     
    any one

    Has anyone got a solusion ?
    Thanks
     
  3. dhub

    dhub Guest

    0
     
    default setting .htaccess

    Try adding a file with filename .htaccess in the directory /httpdocs.

    In this text file, enter:

    <DirectoryIndex index.html>


    You website should display this index.html page.

    Give a try.

    DHUB
     
  4. Deputy

    Deputy Guest

    0
     
    Hi Thanks .htacces file already has this entry
    httpd.conf does not.
    which httpd file does plesk use.
    I am a windows man and linux is proving a bit shy in giving out it secrets ?

    Thanks:mad:
     
  5. phoenixisp

    phoenixisp Silver Pleskian

    27
    57%
    Joined:
    Feb 2, 2002
    Messages:
    840
    Likes Received:
    0
    The domain should resolve without the index.html in the url. Go into the control panel, Server -> IP Addresses and click the link under "Hosting" for the IP you are using. On the next page tic the radio button for the domain and click Set as "default". See if that helps.

    Also, with CentOS the httpd.conf file is in /etc/httpd/conf. I am sure that index.html is listed under DirectoryIndex. (around line 462 or so)
     
  6. Deputy

    Deputy Guest

    0
     
    index.html

    Thanks for Not sure what happened there
    But it appears to be working now

    Thanks again
     
Loading...