1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice

Install Problems

Discussion in 'Plesk for Linux - 8.x and Older' started by AndyD, Oct 20, 2005.

  1. AndyD

    AndyD Guest

    0
     
    I just bought a Plesk licence, and I tried to run the auto installer (psa_installer_v2.0.0_build75050908.11_os_Debian_3.1_i686) but I had a few problems.

    Firstly, there was an error half way through the installer about being unable to resolve hostnames, so I quickly edited my /etc/resolv.conf and found that my name servers had been changed to 127.0.0.1 and nothing else. I changed them back to my ISPs, then restarted the the auto installer.

    This time, I found that lots of packages had become half installed.

    Code:
    Type the number corresponding to the desired action and press Enter [1]:
    Hit [url]http://ftp.uk.debian.org[/url] stable/main Packages
    Hit [url]http://ftp.uk.debian.org[/url] stable/main Release
    Hit [url]http://ftp.uk.debian.org[/url] woody/main Packages
    Hit [url]http://ftp.uk.debian.org[/url] woody/main Release
    Hit [url]http://ftp.uk.debian.org[/url] testing/main Packages
    Hit [url]http://ftp.uk.debian.org[/url] testing/main Release
    Get:1 [url]http://autoinstall.plesk.com[/url] PSA_7.5.4/ Packages [12.5kB]
    Ign [url]http://autoinstall.plesk.com[/url] PSA_7.5.4/ Release
    Fetched 12.5kB in 0s (21.1kB/s)
    Reading Package Lists...
    Reading Package Lists...
    Building Dependency Tree...
    psa-courier-imap is already the newest version.
    psa-courier-imap-add is already the newest version.
    psa-key is already the newest version.
    psa-locale-base-en-us is already the newest version.
    psa-proftpd is already the newest version.
    psa-proftpd-inetd is already the newest version.
    psa-imp is already the newest version.
    mailman is already the newest version.
    j2sdk1.4 is already the newest version.
    j2re1.4 is already the newest version.
    You might want to run `apt-get -f install' to correct these:
    The following packages have unmet dependencies:
      libapache-asp-perl: Depends: libmldbm-perl (>= 2.00-1) but it is not going to be installed
                          Depends: libmldbm-sync-perl (>= 0.25) but it is not going to be installed
      libapache2-mod-python: Depends: libapache2-mod-python2.3 (>= 3.1.3-3) but it is not going to be installed
      libxml2-dev: Depends: libxml2 (= 2.6.16-7) but 2.6.22-1 is to be installed
                   Depends: zlib1g-dev but it is not going to be installed or
                            libz-dev
      libxslt1-dev: Depends: libxslt1.1 (= 1.1.12-8) but 1.1.15-1 is to be installed
                    Depends: zlib1g-dev but it is not going to be installed or
                             libz-dev
                    Depends: libgcrypt11-dev but it is not going to be installed
      php4-imap: Depends: php4-common (= 4:4.3.10-15) but 4:4.3.10-16 is to be installed
      php4-mysql: Depends: php4-common (= 4:4.3.10-15) but 4:4.3.10-16 is to be installed
      postgresql: Depends: postgresql-7.4 but it is not going to be installed
                  Depends: postgresql-client (>= 7.5) but it is not going to be installed
      ppwse: Depends: php4 (>= 4.1) but it is not going to be installed
             Depends: php4-curl but it is not going to be installed
      psa: Depends: bind9 but it is not going to be installed
      psa-appvault-coppermine: Depends: php4-gd
      psa-appvault-gallery: Depends: php4-gd
      psa-bu: Depends: libparse-yapp-perl but it is not going to be installed
              Depends: libxml-parser-perl but it is not going to be installed
              Depends: libxml-perl but it is not going to be installed
              Depends: libxml-dom-perl but it is not going to be installed
              Depends: libxml-xql-perl but it is not going to be installed
              Depends: libio-zlib-perl but it is not going to be installed
              Depends: libmime-lite-perl but it is not going to be installed
              Depends: libparse-recdescent-perl but it is not going to be installed
              Depends: libxml-regexp-perl but it is not going to be installed
              Depends: libdata-showtable-perl but it is not going to be installed
      psa-horde: Depends: php4-domxml but it is not going to be installed or
                          php5-common but it is not installable
      psa-migration-manager: Depends: libtimedate-perl but it is not going to be installed
      psa-spamassassin: Depends: spamassassin (>= 3.0.2) but it is not going to be installed
      sitebuilder: Depends: php4 but it is not going to be installed
                   Depends: php4-domxml but it is not going to be installed
                   Depends: lynx
                   Depends: php4-gd
      whois: Depends: libidn11 (>= 0.5.18) but 0.5.13-1.0 is to be installed
    E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).
    Hit [url]http://ftp.uk.debian.org[/url] stable/main Packages
    Hit [url]http://ftp.uk.debian.org[/url] stable/main Release
    Hit [url]http://ftp.uk.debian.org[/url] woody/main Packages
    Hit [url]http://ftp.uk.debian.org[/url] woody/main Release
    Hit [url]http://ftp.uk.debian.org[/url] testing/main Packages
    Hit [url]http://ftp.uk.debian.org[/url] testing/main Release
    Reading Package Lists...
    Press <ENTER> to continue...
    
    So I pressed Ctrl + C and tried to run 'apt-get -f install' as suggested.

    Code:
    serv02:~/plesk/auto# apt-get -f install
    Reading Package Lists... Done
    Building Dependency Tree... Done
    Correcting dependencies... Done
    The following extra packages will be installed:
      exim4 exim4-base exim4-config exim4-daemon-light libgcrypt11-dev libgnutls12 libgpg-error-dev libidn11 libxml2-dev libxslt1-dev php4-imap php4-mysql
      zlib1g-dev
    Suggested packages:
      eximon4 exim4-doc-html exim4-doc-info gnutls-bin
    The following packages will be REMOVED:
      psa-courier-imap-add psa-imp
    The following NEW packages will be installed:
      exim4 exim4-base exim4-config exim4-daemon-light libgcrypt11-dev libgnutls12 libgpg-error-dev zlib1g-dev
    The following packages will be upgraded:
      libidn11 libxml2-dev libxslt1-dev php4-imap php4-mysql
    5 upgraded, 8 newly installed, 2 to remove and 32 not upgraded.
    41 not fully installed or removed.
    Need to get 0B/3833kB of archives.
    After unpacking 7327kB disk space will be freed.
    Do you want to continue? [Y/n] y
    Preconfiguring packages ...
    (Reading database ... 31918 files and directories currently installed.)
    Removing psa-courier-imap-add ...
    /var/lib/dpkg/info/psa-courier-imap-add.postrm: line 43: /etc/courier-imap/imapd: No such file or directory
    mv: cannot stat `/etc/courier-imap/imapd.purg': No such file or directory
    /var/lib/dpkg/info/psa-courier-imap-add.postrm: line 43: /etc/courier-imap/imapd: No such file or directory
    mv: cannot stat `/etc/courier-imap/imapd.purg': No such file or directory
    /var/lib/dpkg/info/psa-courier-imap-add.postrm: line 43: /etc/courier-imap/pop3d: No such file or directory
    mv: cannot stat `/etc/courier-imap/pop3d.purg': No such file or directory
    /var/lib/dpkg/info/psa-courier-imap-add.postrm: line 43: /etc/courier-imap/pop3d: No such file or directory
    mv: cannot stat `/etc/courier-imap/pop3d.purg': No such file or directory
    /var/lib/dpkg/info/psa-courier-imap-add.postrm: line 43: /etc/courier-imap/imapd-ssl: No such file or directory
    mv: cannot stat `/etc/courier-imap/imapd-ssl.purg': No such file or directory
    /var/lib/dpkg/info/psa-courier-imap-add.postrm: line 43: /etc/courier-imap/imapd-ssl: No such file or directory
    mv: cannot stat `/etc/courier-imap/imapd-ssl.purg': No such file or directory
    /var/lib/dpkg/info/psa-courier-imap-add.postrm: line 43: /etc/courier-imap/pop3d-ssl: No such file or directory
    mv: cannot stat `/etc/courier-imap/pop3d-ssl.purg': No such file or directory
    /var/lib/dpkg/info/psa-courier-imap-add.postrm: line 43: /etc/courier-imap/pop3d-ssl: No such file or directory
    mv: cannot stat `/etc/courier-imap/pop3d-ssl.purg': No such file or directory
    Stopping Courier-IMAP server:
    /etc/init.d/courier-imap: line 193: /etc/courier-imap/imapd: No such file or directory
    dpkg: error processing psa-courier-imap-add (--remove):
     subprocess post-removal script returned error exit status 1
    Removing psa-imp ...
    Unable to find product configuration file: /etc/psa/psa.conf
    
    ERROR while trying to Unable to get admin password
    Check the error reason(see log file: /tmp/imp-4.0.3.log), fix and try again
    
    Aborting...
    
    dpkg: error processing psa-imp (--remove):
     subprocess post-removal script returned error exit status 1
    Errors were encountered while processing:
     psa-courier-imap-add
     psa-imp
    E: Sub-process /usr/bin/dpkg returned an error code (1)
    
    So now I can't run the installer, or fix the package problems - and I don't know what to do.

    Any suggestions?
     
  2. roberto@

    roberto@ Guest

    0
     
    any suggestions to solve this. i have the same problem.

    # apt-get -f install
    Reading Package Lists... Done
    Building Dependency Tree... Done
    The following packages will be REMOVED:
    psa-imp
    0 upgraded, 0 newly installed, 1 to remove and 0 not upgraded.
    1 not fully installed or removed.
    Need to get 0B of archives.
    After unpacking 11.8MB disk space will be freed.
    Do you want to continue? [Y/n] Y
    (Reading database ... 83442 files and directories currently installed.)
    Removing psa-imp ...

    ERROR while trying to Unable to get admin password
    Check the error reason(see log file: /tmp/imp-4.0.3.log), fix and try again

    Aborting...

    dpkg: error processing psa-imp (--remove):
    subprocess post-removal script returned error exit status 1
    Errors were encountered while processing:
    psa-imp
    E: Sub-process /usr/bin/dpkg returned an error code (1)
     
  3. AndyD

    AndyD Guest

    0
     
    I got this message from Plesk support. I didn't use this because it was quicker for me to drive to the data centre and reinstall Debian and Plesk - but I hope it helps!:

    Dear Andy,

    Please remove sources to woody and testing in /etc/apt/sources.list and
    run command
    apt-get update

    After that you should run the following commands:
    dpkg -r --force-all psa-courier-imap-add
    dpkg -r --force-all psa-imp
    rm /var/lib/dpkg/info/psa-courier*
    rm /var/lib/dpkg/info/psa-imp*
    apt-get -f install

    If there will be any problems please let us know.
     
  4. roberto@

    roberto@ Guest

    0
     
    Hi

    I have used your instructions and it worked. But I have a new error!

    :confused:

    Have a look at this. I'm lost.

    #dpkg -i psa_7.5.4-debian3.1.build75050824.12_i386.deb
    ...
    dpkg: dependency problems prevent configuration of psa:
    psa depends on libapache2-mod-perl2; however:
    Package libapache2-mod-perl2 is not installed.
    psa depends on psa-api-common (>= 7.5.4-debian3.1.build75050824.12); however:
    Package psa-api-common is not installed.
    psa depends on psa-api-cli (>= 7.5.4-debian3.1.build75050824.12); however:
    Package psa-api-cli is not installed.
    dpkg: error processing psa (--install):
    dependency problems - leaving unconfigured
    Errors were encountered while processing:
    psa


    #apt-get install libapache2-mod-perl2
    Reading Package Lists... Done
    Building Dependency Tree... Done
    You might want to run 'apt-get -f install' to correct these:
    The following packages have unmet dependencies:
    libapache2-mod-perl2: Depends: libperl5.8 (>= 5.8.4) but it is not going to be installed
    psa: Depends: psa-api-common (>= 7.5.4-debian3.1.build75050824.12) but it is not installable
    Depends: psa-api-cli (>= 7.5.4-debian3.1.build75050824.12) but it is not installable
    psa-hotfix5: Depends: psa-hotfix but it is not installable
    Depends: psa-hotfix2 but it is not installable
    Depends: psa-hotfix3 but it is not installable
    Depends: psa-hotfix4 but it is not installable
    E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).

    # apt-get -f install
    Reading Package Lists... Done
    Building Dependency Tree... Done
    Correcting dependencies... Done
    The following packages will be REMOVED:
    psa psa-hotfix5 psa-imp
    0 upgraded, 0 newly installed, 3 to remove and 0 not upgraded.
    3 not fully installed or removed.
    Need to get 0B of archives.
    After unpacking 147MB disk space will be freed.
    Do you want to continue? [Y/n] y
    (Reading database ... 96039 files and directories currently installed.)
    Removing psa-hotfix5 ...
    Removing psa ...
    Removing psa-imp ...

    ERROR while trying to Unable to get admin password
    Check the error reason(see log file: /tmp/imp-4.0.3.log), fix and try again

    Aborting...

    dpkg: error processing psa-imp (--remove):
    subprocess post-removal script returned error exit status 1
    Errors were encountered while processing:
    psa-imp
    E: Sub-process /usr/bin/dpkg returned an error code (1)


    -------------------ideas?
     
Loading...