• The new Python extension is now available. It allows customers to deploy and manage WSGI-based Python applications on their websites directly from Plesk.
  • Debian 11 has reached its end-of-life (vendor EOL date - August 31, 2026). Plesk Obsidian 18.0.81 is the last release to support it.
    If you are running Plesk Obsidian on Debian 11, we recommend you upgrade those servers to Debian 12 using our dist-upgrade tool.
  • We plan to deprecate and remove the support for XML RPC protocol versions earlier than 1.6.9.1 in Plesk Obsidian 18.0.82. We strongly recommend that you update all existing integrations using earlier versions of the XML RPC protocol to comply with the version 1.6.9.1 specification.

Installation error, help me...

N

nunovzl

Guest
ERROR: Unable to install the "psa-8.2.1-cos4.build82070918.10.i586" package.

The following could cause the installation failure:
Packages "php-4.3.9-3.22.5.i386" and "php-4.3.9-3.22.9.i386" cannot be installed at the same time
because of the conflict on the file "/etc/httpd/conf.d/php.conf"



Not all packages were installed.
Please, contact product technical support.

I resolve this problem?

thanks
 
Hi,

check what package is installed on your server with rpm -q command;
this error mean that two packages of different versions are has been installed (just an attempt)
how do you try to install?
 
Originally posted by nunovzl
ERROR: Unable to install the "psa-8.2.1-cos4.build82070918.10.i586" package.

The following could cause the installation failure:
Packages "php-4.3.9-3.22.5.i386" and "php-4.3.9-3.22.9.i386" cannot be installed at the same time
because of the conflict on the file "/etc/httpd/conf.d/php.conf"



Not all packages were installed.
Please, contact product technical support.

I resolve this problem?

thanks

The error is produces by Plesk autoinstaller.

It is caused by the fact that PHP is already installed on the server, PHP has version different from one that Plesk autoinstaller requires.
Plesk autoinstaller is configured to check system PHP and install or update it to '4.3.9-3.22.5.i386' if PHP version does not match it.

In your case you have newer PHP (4.3.9-3.22.9.i386) and Plesk autoinstaller is still trying to install 4.3.9-3.22.5.i386. It failed because can not install rpm packages with '--oldpackage' or '--force'.

You have two ways to resolve this problem and update Plesk:
1. install older PHP version 4.3.9-3.22.5.i386, required by Plesk autoinstaller;
2. do not use Plesk autoinstaller and update Plesk rpm packages manually (rpm -Uvh).

./anb
 
Back
Top