• Debian 11 has reached its end-of-life (vendor EOL date - August 31, 2026). Plesk Obsidian 18.0.81 is the last release to support it.
    If you are running Plesk Obsidian on Debian 11, we recommend you upgrade those servers to Debian 12 using our dist-upgrade tool.
  • We plan to deprecate and remove the support for XML RPC protocol versions earlier than 1.6.9.1 in Plesk Obsidian 18.0.82. We strongly recommend that you update all existing integrations using earlier versions of the XML RPC protocol to comply with the version 1.6.9.1 specification.

Kaspersky renewal got North....

yurka

New Pleskian
Hi all,

I needed to renew Kaspersky antivirus, after getting the key file I uploaded it to the Plesk throw Administration Panel and replaced the old one. On the License manager screen in Admin Panel I saw the new expiration date, but in /usr/local/psa/var/log/maillog it still got the old expired date and did not worked. From this moment, everything got down.

I tried to restart the Kaspersky service throw the administration panel, didn't help. I removed and installed from beginning the license key in Admin Panel, didn't help. I tried to restart the Kav and started to get errors, the Kav service could not be started, with Unknown error in maillog file.
I removed the Kaspersky at all by "yum remove psa-kav8" and the license from the Admin Panel, and installed it again throw Adminh Panel->Updates, same thing, Kav service failed to start.

Now the status that Kav installed but in Admin Panel-> Services it shown as grey (as it not installed), manual start from shell "/etc/init.d/kavhost start" return FAILED and updated license installed.
1. Any thoughts how can I activate Kav in Admin Panel-> Services?
2. Where can I find the logs at manusl start on service? In maillog nothing shown.

I am using RedHat 5, Plesk Panel 10.2.

Thanks in advance.
Yuri
 
After some digging, I found out that in:
/opt/kav/sdk8l3/bin/ file name kav.key was missing. After copying it from saved install Kav service started, but when running kav8update I see:
Code:
Loading engine...
Current product version: 8.0.1.25
Initializing engine...
Using xml-file: /opt/kav/sdk8l3/bin/settings.xml.

LICENSE INFO:
Key file: kav.key
Expiration date: 24/02/2013

My new license should be until 2014, any idea why this kav.key did not updated?

Edited:

After restarting the server service FAILED to start again.....

One more Update:
Even the Kav is running and the License updated in Plesk Panel, in maillog I still see:
Code:
Mar  6 09:27:44 rhser kav-handler[27595]: Scan: KAV_E_LICENSE_EXPIRED_OR_MISSING no valid licence found or license expired
I think for some reason the kav.key file does not updating. Is there a way to update this file manually?

Yuri
 
Last edited:
Back
Top