1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Mailman Install Problem

Discussion in 'Plesk for Linux - 8.x and Older' started by Greg Sims, Feb 14, 2007.

  1. Greg Sims

    Greg Sims Basic Pleskian

    25
     
    Joined:
    Jan 22, 2007
    Messages:
    30
    Likes Received:
    0
    Hi There,

    I installed Mailman from the Plesk 8.0.1 control panel and was able to access the web GUI for mailman. I created the list testing@dom.ain which seemed to go OK. I added one email address to the testing list and logged out of the GUI.

    I sent an email to testing@dom.ain and received an error message:
    <testing@dom.ain>:
    70.87.67.34 does not like recipient.
    Remote host said: 550 sorry, no mailbox here by that name. (#5.7.17) Giving up on 70.87.67.34.

    I looked at the Plesk Control panel and found there was no email group created named "testing" under raystedman.org. This seems to be consistent with no mailbox found. Other email operations are working fine on this box.

    There seems to be a connection between Mailman and Qmail that needs to be completed.

    This installation of mailman was performed when most of the production DNS records for this domain were pointing to another server. This may have been the root cause of the problem. The DNS is now all pointing to this box.

    Thanks in advance for your help! Greg

    PS. Perhaps removing Mailman so that Plesk believes it is not installed and re-installing mailman from Plesk is the answer. I will give this a try if someone can help me accomplish the uninstall of mailman.
     
  2. nomaddesign

    nomaddesign Guest

    0
     
    Mailman Uninstall

    I'm also looking for instructions on uninstalling mailman... Shame on Plesk for a one button intall with no strait-forward uninstall. A warning is needed here.
     
  3. nomaddesign

    nomaddesign Guest

    0
     
    uninstall mailman

    I found a 7.5 thread http://forum.swsoft.com/showthread.php?postid=111665 that suggests uninstalling mail via the package installer.

    I trid this and got:

    [root@as serverurl.com]# rpm -e mailman-2.1.5.1-34.rhel4.5
    error: Failed dependencies:
    mailman >= 2.1 is needed by (installed) psa-mailman-configurator-8.1.1-cos4.build81070322.16.i586

    any ideas?

    Thanks!
     
  4. DCNet_James

    DCNet_James Guest

    0
     
    Yah, you from what you wrote, you're using PSA 8.0.1 and you installed Mailman for 8.1.1 according to the error. They're not going to mesh well together.

    Qmail in PSA uses the $PRODUCT_ROOT/qmail/bin/mm_wrapper to process listserv emails. A mailbox is not actually created within PSA under the domain for it.

    I'd verify first of all what version of PSA you're using, second I'd look to see what version of Mailman you installed, and third look to see if the mm_wrapper is there.

    Thanks,
    James
     
  5. nomaddesign

    nomaddesign Guest

    0
     
    Uninstalling mailman

    James,

    Thanks for sheading some light on PSAs mailman.

    There are two posters on this thread looking for info:

    Greg Simms is the origional poster who is on PSA 8.0.1 who has a qmail / mailman disconnect

    I'm nomaddesign and I'm on PSA 8.1.1 and I'm the one who got Failed dependencies when attemping an RPM uninstall. (I'm just tring to get rid of mailman )

    I've moved my question over to the 8.1.1 'How do I' forum to avoid further confusion:
    http://forum.swsoft.com/showthread.php?s=&threadid=44162

    Cheers,

    Jason (nomaddesign)
     
  6. DCNet_James

    DCNet_James Guest

    0
     
    Sorry for the confusion...

    Gregsims, I hope my answer helps you.

    Nomad, good luck.

    Thanks,
    James
     
Loading...