1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Missed mod_webapp.so !!!

Discussion in 'Plesk for Linux - 8.x and Older' started by alireza, Feb 12, 2006.

  1. alireza

    alireza Guest

    0
     
    Hey guyz;
    I was goin to start my httpd while I got the following error"

    Code:
    [root@localhost TOMCAT]# service httpd start
    Starting httpd: Syntax error on line 1064 of /etc/httpd/conf/httpd.conf:
    Cannot load /usr/lib/httpd/modules/mod_webapp.so into server: /usr/lib/httpd/modules/mod_webapp.so: undefined symbol: ap_palloc
                                                               [FAILED]
    [root@localhost TOMCAT]#
    I'm using "tomcat-4.1.27-13" with "httpd-2.0.51-2.9.4.legacy" , I got that "mod_webapp.so" is missed, tried to find some on the web, but they're all different version than I have, I am using FedoraCore 2.
    any help appreciated, tnx ;)
     
  2. wagnerch

    wagnerch Guest

    0
     
    This is not saying mod_webapp.so is missing, it is saying mod_webapp.so is referencing an undefined symbol. How about you start with a little history, such as: 1. Did you rebuild httpd manually? 2. Did you rebuild tomcat manually? 3. What verison of Plesk, is it for FC2?

    I am using Fedora Core 2, httpd-2.0.51-2.9.4.legacy and I am not having any problems with mod_webapp from Plesk 7.5.4 for FC2.
     
  3. alireza

    alireza Guest

    0
     
    Re: Re: Missed mod_webapp.so !!!

    it was missing , i replaced with another one ;) thats why ...

    1- NO
    2- YES, Reinstalled !
     
  4. wagnerch

    wagnerch Guest

    0
     
    Re: Re: Re: Missed mod_webapp.so !!!

    Ahh, that explains it. Here is what I would do:

    find /var/psa -name "mod_webapp*"

    Find the right version of Plesk/OS and "rpm --force -Uvh" that file. If you upgraded from 7.5.3 to 7.5.4 then mod_webapp may be the one that came with Plesk 7.5.3 (or maybe even an older version).

    Then you will probably have to restart Apache.
     
  5. alireza

    alireza Guest

    0
     
    Re: Re: Re: Re: Missed mod_webapp.so !!!

    dude, I already did these all, what i need now is the right version of mod_webapp.so , someone with FedoraCore2 can send it to me plz?:confused:
     
  6. wagnerch

    wagnerch Guest

    0
     
    Re: Re: Re: Re: Re: Missed mod_webapp.so !!!

    I told you where to find it, Plesk keeps a copy of the original RPMs. Just force upgrade it like I said and you would be fine.

    Otherwise continue on screwing up your installation.
     
Loading...