1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Okay - this is probably stupid - but I need help...

Discussion in 'Plesk for Linux - 8.x and Older' started by EnigmaBurn, Jun 7, 2005.

  1. EnigmaBurn

    EnigmaBurn Guest

    0
     
    Hello all! I hope someone can help me here. I know this site is for Plesk specifically, but I am hoping one of you gurus can help me. Besides, I have no idea if this might have some permission or setting in Plesk, as the problem is bewildering...

    I have a script that I use internally to submit my site's news to a MySQL DB, which is then obviously used publically and is quite popular; not to mention that the RSS feed (XML) produced from the database powers other bits of my site...

    Now I have been using this script for more than a year. It is simpler than hell. A basic PHP if/else statement that says if (parameter) then display submit form, else display last 6 entries (with option to add, a link which essentially throws "?add=1" to the url, throwing the parameter to the PHP-SELF object).

    For some #$@&in' reason when I migrated to a dedicated host with Plesk the %@*&% stopped working?!?! Sure database information changed, and I updated it. BUT remember that if the else (no parameter) statement is run it displays the last 6 entries - and that's just it - it DOES display the last six entires so surely it is not having a problem accessing the database....

    The problem is when I click the link on the default display, to throw the parameter (/submit-rss.php?add=1) the same damned default view comes up...?

    I have no idea why this is - other legacy files in the same directory with the same permissions are reading parameters thrown in the url...? I tried a bunch of stuff and hope some one here has a 'You idiot, do this:' sort of answer for which I would be ever so grateful.

    Thanks much in advance!
     
  2. jamesyeeoc

    jamesyeeoc Guest

    0
     
    This may seem like a trivial thing, but worth checking....

    Make sure your domain is set as the default for the IP address.

    Currently if you browse to the IP for your domain, it brings up the Fedora Core Apache Test page instead of your site's page.
     
  3. EnigmaBurn

    EnigmaBurn Guest

    0
     
    Good idea...

    This sounds like a godo idea... How do I check or set that?

    Many thanks!
     
  4. jamesyeeoc

    jamesyeeoc Guest

    0
     
    In the control panel, Server, IP Addresses.

    If you only have a single IP, then click the number under the 'H' on the end of the line, otherwise click the number under the 'H' on the end of the line which has the IP for your domain.

    Then put a dot in the radio button for your primary domain, and click the link above it for 'Set as default'.

    This will associate the selected domain with the IP address as the 'default' domain to bring up if someone browses to the http://<ipaddress>
     
  5. EnigmaBurn

    EnigmaBurn Guest

    0
     
    Hmmmm...

    Sounds like a nice idea and all. But I have ten domain and an 11th via another client that are all sharing the same IP... In addition, I only have the one IP address so I can't do this - I don't think...?

    Any other thoughts or is there another way to do this?
     
  6. jamesyeeoc

    jamesyeeoc Guest

    0
     
    Setting a default domain will not prevent the other domains from working, it just sets the 'default' for the IP. The other domains will still operate properly since this is virtual hosting. And assuming none of the other domains are using similar scripts, then they won't be affected.

    Heck, I'm not even sure it's specifically related to your problem, but I'd say it's worth a shot.

    I always set a default domain for each IP on my servers.
     
  7. EnigmaBurn

    EnigmaBurn Guest

    0
     
    I agree it is worth a try and I would love to, but the interface does not seem to offer the ability to change that from the server >> ip address... There is no 'H' at the end of the line - only an 'S' (Status) and a 'T' (Type) and at the end of the line these is a radio input, but just to remove it, which would be bad, and as such it is not available...

    If I go into the IP address dialog itself, it does have "Shared" and "Exclusive" radio buttons, but it throws an error if I try changing them saying '11 domains and 2 clients share that IP'... And I can see 'Default domain' none... But there is no way to chage that entry....

    Is there a file I can edit in Linux by chance that would let me set this variable?
     
  8. jamesyeeoc

    jamesyeeoc Guest

    0
     
    In the mySQL 'psa' database, in the 'DOMAINS' table, lookup your 'id' field for the domain.

    In the mySQL 'psa' database, in the 'IP_ADDRESSES' table, if your domain's ID is '1', then set value '1' for 'default_domain_id' for the IP address in question.

    If your domain's ID is '3', then set it for '3', etc.

    Are you running on a VPS server?
     
  9. LeeParker

    LeeParker Guest

    0
     
    In the CP - system/servers/IP addresses - look for "Hosting" click on the number below it on the line your domain IP is on. That'll take you to the page you set your default domain.
     
  10. jamesyeeoc

    jamesyeeoc Guest

    0
     
    Hey Lee, he already posted that on his installation (maybe a VPS) that he does not have the 'H' on the end of the line. That's why I gave him the alternative of doing it in mySQL.
     
  11. LeeParker

    LeeParker Guest

    0
     
    I know, but I'm so new to this server thing that that I might want a literal translation. <G> Might not think that "H" was the same as "Hosting"
     
  12. jamesyeeoc

    jamesyeeoc Guest

    0
     
    Cool, got it now.:D
     
Loading...