1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

open_basedir errors on Suse 10.0 with PHP 5

Discussion in 'Plesk for Linux - 8.x and Older' started by phorium, Jun 6, 2006.

  1. phorium

    phorium Guest

    0
     
    I have a fresh install of Suse 10.0 running Plesk 8. The server is set up running php 5 using the apache module. Any page I visit on the server gives an open_basedir error message claiming the following:

    Warning: %v%v() [function.%v]: open_basedir restriction in effect.
    File(/usr/share/php5/config.inc.php) is not within the allowed path(s):
    (/srv/www/vhosts/domain.com/subdomains/somename/httpdocs:/tmp)

    Checking the php.ini file (/etc/php5) shows that /usr/share/php5 is set as the include path, but the error still persists.

    Creating a vhost.conf file and adding /usr/share/php5 to the open_basedir setting fixes the problem, but I don't want to have to create a custom vhost.conf file for every domain I add on the server. What Plesk file can I edit to include this directory by default??
     
  2. jd2004

    jd2004 Guest

    0
     
    I have the same problem, also Suse 10 and Plesk 8!

    Is this an issue that needs to be solved by SWsoft?

    JD.
     
  3. belyakov

    belyakov Guest

    0
     
    Maybe you can try to edit the .skeleton for all created domains (include the conf dir)
     
  4. MrTi

    MrTi Guest

    0
     
    Did somebody solve this Issue, because i have exact same situation.

    thx
     
  5. phorium

    phorium Guest

    0
     
    It has not been solved (AFAIK) yet, and I have not tried to add the .conf file in the .skeleton as you'd still need to go in and customize the file for each directory anyway (unless there's some way to auto-populate the proper directory value)

    I have noticed, however, that this only occurs when installing certain applications that require that shared folder for some reason. For instance, we were running an installation of cube cart and it was giving us that error - other sites don't seem to need the shared directory. So for now, I'm still adding it manually when needed.
     
  6. LeaderGL

    LeaderGL Guest

    0
     
    if you try in your php script to do:

    Code:
    ini_set('include_path', '.');
    
    or
    Code:
    ini_set('include_path', '/srv/www/vhost/DOMAINNAME/httpdocs');
    
    you should solve your problem...

    i think is a wrong php.ini setting also because /usr/share/php5 is empty...
     
Loading...