1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Password Protect Directory Cant Access!

Discussion in 'Plesk for Linux - 8.x and Older' started by devindull, Nov 16, 2005.

  1. devindull

    devindull Guest

    0
     
    I have tried to password protect our catalog/admin directories for our oscommerce websites. However, when I password protect it, I have to restart Apache for it to even pop up the box for the password. When I try to access it through that box, the username/password is invalid so I get the not authorized screen. Also, when I tried to delete the Password Protect to redo it, the only was to remove it was to delete the files using my FTP and then to restart Apache again. Any ideas on how to get this to work properly?
     
  2. ShadowMan@

    ShadowMan@ Guest

    0
     
    Having to manually restart Apache sometimes happens, Plesk is supposed to do this by itself, but there are other things which can cause Apache not to restart properly from the Plesk GUI.

    When a directory is password protected, Plesk is supposed to put into that domain's httpd.include file, something like:
    Code:
            <Directory "/home/httpd/vhosts/example.com/httpsdocs/test">
                    AuthType Basic
                    AuthName "Login Required for Test folder"
                    AuthUserFile /home/httpd/vhosts/example.com/pd/d..test
                    require  valid-user
            </Directory>
    
    and supposed to create the appropriate file which will contain the username and password like:
    Code:
    cat d..test
    user1:$1$mTx5ifeo$ITULwvLoyGO07YudTjHyv.
    the password is encrypted/hashed (MD5?)

    Please check to see that it is doing these things
     
  3. David Duggins

    David Duggins Guest

    0
     
    I have a similar issue right now. My client is using Plesk 9.2 Linux on a GoDaddy private Server. I have set a password protected directory as per the documentation. The includes file IS created, as if the password file in pd directory. I have restarted the server, allowed it time, waited, tried again and again. I cannot get this to work. The login box appears as soon as I lock the directory, but the username/password are never accepted. If I have to, I'll manually lock it with htaccess, but I'd rather the client have the interface through plesk to add users and change passwords. Any thoughts?
     
Loading...