1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Plesk 10.4.4 SSL issue

Discussion in 'Plesk 10.x for Linux Issues, Fixes, How-To' started by IgoKonrads, Mar 19, 2012.

  1. IgoKonrads

    IgoKonrads Guest

    0
     
    Hi guys. Hope someone can point me the right direction here?
    ---------------------------------------------------------------

    PLESK, 10.4.4 MU22, CENTOS 6, 64bit

    PROBLEM - cant get SSL certificate to work. I have uploaded an SSL certificate to my only domain on this server which has SSL turned on and this sertificate added to it as well as this domain being the default one for the only ip which I use as dedicated. When i check on the front end I keep seeying the server default certificate. In the ip list I dont see the newly uploaded certificate under settings although I have asigned this IP to this subscription.. If i create a new certificate under the server settings -> Certificates and add it to my ip as default, i still see the old default certificate. This is a newly launched ecommerce site that currently runs with no SSL support so extremly urgent to fix..

    --------------------------------------------------------------
    kind Regards,
    igo
     
  2. IgoKonrads

    IgoKonrads Guest

    0
     
    Dear plesk team - can you please point me the right direction?
     
  3. Mshaker

    Mshaker Basic Pleskian

    18
    85%
    Joined:
    Oct 21, 2010
    Messages:
    75
    Likes Received:
    0
    bug in plesk 10.4

    I ran into this same issue. You need to make sure that the ssl certificate is activated by going to :

    websites and domains -> click on the domain name -> Under security check mark "Enable SSL support" then select the ssl certificate.

    The bug is that it still won't activate the certificate until you do:

    Tools and settings -> IP address management -> select the dedicated IP address for the website -> then select the website from under "default site".

    It's a bug that hopefully will get fixed soon!
     
  4. IgoKonrads

    IgoKonrads Guest

    0
     
    Thanks for your reply. I have done it exactly as you said but when i type https://www.domain.tld I get the default SSL certificate which is self signed etc and not the one set up for the website. God this client is getting pissed off more and more with every hour that passes and no one from Plesk cares to try and help me sort this out.

    This is not me doing something wrong, this is an actual bug in Plesk Control Panel! I have tried about 20 times now to do the same thing but nothing works. The exact same setup works on another of my servers which is Centos 5.6 Plesk 10.4.4 MU22 so the only difference is the Centos version.
     
  5. IgoKonrads

    IgoKonrads Guest

    0
     
    Desperate

    I have now tried everything and turned Google upside down trying to fix this issue with no luck. Amazingly no-one from Plesk have bothered to help me out either so at the moment I am a very frustrated customer. Can anyone please have any guesses at least what could be the issue? I checked the latest vhosts.conf file and copied the link to the SSL certificate set to be used only to find out there was no such file on the server. I created it and pasted the certificate in there, stopped and started the httpd, but still no luck. The default certificate is still being served.
     
  6. pierre88

    pierre88 Basic Pleskian

    23
    23%
    Joined:
    Jun 7, 2007
    Messages:
    28
    Likes Received:
    0
    I have the SAME problem, i tried 10 times and no way to solve it, psa stopped and started, httpd stopped and started too, no way!

    I use the same version too! Where is plesk support team???
     
  7. mc49285

    mc49285 Guest

    0
     
    Busy defending themselves over in Web Hosting Talk.

    I have the same issue, and fortunately have the option of switching to CPanel. I simply cannot customers greeted by that security greeting when they access Plesk on their own. What really makes this bad is that the supplied default certificate expired three years ago and is not even registered to Plesk.

    The certificate is not trusted because it is self-signed.
    The certificate is only valid for ares.sw.ru
    The certificate expired on 6/30/2009 8:51 AM. The current time is 4/1/2012 3:22 AM.
     
  8. IgorG

    IgorG Forums Analyst Staff Member

    49
    24%
    Joined:
    Oct 27, 2009
    Messages:
    24,572
    Likes Received:
    1,243
    Location:
    Novosibirsk, Russia
  9. pierre88

    pierre88 Basic Pleskian

    23
    23%
    Joined:
    Jun 7, 2007
    Messages:
    28
    Likes Received:
    0
  10. pierre88

    pierre88 Basic Pleskian

    23
    23%
    Joined:
    Jun 7, 2007
    Messages:
    28
    Likes Received:
    0
    So, no solutions??
     
  11. Blake@Parallels

    Blake@Parallels Regular Pleskian

    24
    73%
    Joined:
    Jul 28, 2008
    Messages:
    168
    Likes Received:
    0
    Location:
    Seattle, WA
    The "green" bar in your browser is only for EV (Extended Validation) certificates. Make sure that you have one of these.
     
  12. partywolf

    partywolf New Pleskian

    13
    60%
    Joined:
    Oct 24, 2011
    Messages:
    19
    Likes Received:
    0
    I've followed every article I can find on how to do this. As I understand it with Server Name Indication (SNI), I should be able to have each domain on it's own SSL still with the shared IP address. However, like the others above, I only get the default SSL.

    Mshaker
    "The bug is that it still won't activate the certificate until you do:
    Tools and settings -> IP address management -> select the dedicated IP address for the website -> then select the website from under "default site"."


    When I do this, the site works but all other sites with that shared IP also get that site's SSL certificate (and they get the ugly untrusted warning).

    Is this actually a bug and if so is it being fixed? When can we expect an update?

    Thanks
     
  13. IskrenV

    IskrenV New Pleskian

    10
     
    Joined:
    May 31, 2012
    Messages:
    1
    Likes Received:
    0
    This may prove to be a serious hole. What if a man in the middle is scanning for requests on port 8443 and redirecting them to his own forged Plesk login to collect some users/passwords? ;)
     
  14. fearz

    fearz Regular Pleskian

    25
    57%
    Joined:
    Feb 29, 2008
    Messages:
    170
    Likes Received:
    0
    None of KB works

    I tried all the mentioned solutions and NONE work...my website STILL show the old certificate!

    Can someone help?

    Symptoms
    The wrong certificate is displayed when I open any domain via HTTPS. I added the correct certificate under server settings, assigned this certificate to an IP, set the default domain for the IP, and restarted Apache. But if I open https://domain.tld, I still get a localhost.localdomain (or another) default certificate.
    Cause & Resolution
    Unfortunately, the cause is still unclear. If you have time and will to cooperate in this problem investigation, please report your case to our support team. Feel free to use the available support options in our Support portal (in the menu on the left).
     
  15. 64bithost.com

    64bithost.com Regular Pleskian

    25
    57%
    Joined:
    Jul 30, 2007
    Messages:
    182
    Likes Received:
    0
    SSL Problem

    Have you tried restarting Apache?
     
  16. JustinGivens

    JustinGivens Basic Pleskian

    15
    85%
    Joined:
    Dec 31, 2011
    Messages:
    60
    Likes Received:
    0
    Just had this issue

    I just had this issue. I did the following to fix.

    Went to /var/www/vhosts/domain.tld/conf and look at the last config file to see what certificate it was using.

    Within the conf look for "<VirtualHost X.X.X.X:443>"; then look for "SSLCACertificateFile" setting. Then I looked at that file and notice it was wrong. (If you don't have this then look at SSLCertificateFile setting to confirm it using the wrong file.)

    Then I looked at that certificate(s). It was sending the wrong one.

    So I then stopped httpd service. You can't restart, it doesn't change anything. Waited 15 seconds. Then started the service. Then I went into the Tools & Settings -> SSL Certificates and notice the Used Counter had changed to the default.

    Now go back to Tools & Settings -> IP addresses management and change it to use the correct certificate.

    Mine was displaying that it was using the "default certificate". I changed it to my new certificate and it worked. I went back to double checked the latest config file and it was using the correct Certificate. I don't know if this will work for all but its worth a try.
     
  17. SteffenM

    SteffenM New Pleskian

    15
    85%
    Joined:
    Jun 9, 2010
    Messages:
    8
    Likes Received:
    0
    Same issue

    Hi there,

    I seem to have the same issue:
    I have just moved a site from an plesk 9 system to an 10.1.1 system (opensuse). I had a certificate installed for the domain on the "old" system. Sure, it was used for other sites that run on the same domain, but this was ok for me.

    Now I have "re-keyd" the certificate and installed it for the website (abonnement or whatever it is called in the new psa-version). In every forum-post and in the Plesk-documentary I read: "Switch on the SSL-Checkbox in the Hosting-Settings and then select the Certificate from the Select-Box." BUT THERE IS NO SELECT-BOX!!!

    I'm going crazy: I searched over 3 hours for something that should work in minutes!

    I also read that you should select the website in the global settings as default-website for the IP-address but I really don't want to do this! Should this be the only way??? It wasn't in Plesk 9!!!
    What about this "great" SNI that they talk about???

    FYI: I have tried to restart apache and psa - nothing.

    Is there any help or new information about that issue?
    If there really is a bug causing it, why isn't there a fix in the updates? Or is there one to download anywhere?

    Best regards,
    Steffen
     
  18. Blake@Parallels

    Blake@Parallels Regular Pleskian

    24
    73%
    Joined:
    Jul 28, 2008
    Messages:
    168
    Likes Received:
    0
    Location:
    Seattle, WA
    SNI was added to Plesk 10.2. That said, both 10.1.1 and 10.2 are very old versions. Our latest 10.x version is Plesk 10.4 (and actually, Plesk 11.0 was released today). I would recommend updating then trying again:

    10.x: www.parallels.com/download/plesk/10
    11.x: www.parallels.com/download/plesk/11
     
  19. DanW2102

    DanW2102 Guest

    0
     
    Still the same old error

    I've had this issue for a number of weeks now:

    I've confirmed the sucessful installation of my SSL cert and it works fine in Fifefox, safari, chrome, opera... just not IE, I get the following error: "There is a problem with this website's security certificate." claiming that the SSL installed is Plesks root SSL and not my own certificate.

    I've spent countless hours trying *everything* you can think of, from modifying permissions, upgrading & downgrading plesk, restarting services - nothing works.

    If anyone could offer a solution to this other than "Move to a Windows VPS and use IIS", I'd love to hear it.

    Thanks
     
  20. Blake@Parallels

    Blake@Parallels Regular Pleskian

    24
    73%
    Joined:
    Jul 28, 2008
    Messages:
    168
    Likes Received:
    0
    Location:
    Seattle, WA
    Are you running Windows XP?
     
Loading...