1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

plesk 7.5 problem.

Discussion in 'Plesk for Linux - 8.x and Older' started by LastOttoman, Dec 20, 2004.

  1. LastOttoman

    LastOttoman Guest

    0
     
    Unable to create Session object: Unable to set up default locale: default locale does not exist or undefined. 0: /usr/local/psa/admin/auto_prepend/auth.php3:2 psaerror(string "Unable to create Session object: Unable to set up default locale: default locale does not exist or undefined.")
     
  2. RedWolfX

    RedWolfX Guest

    0
     
    I am having the *exact* same problem. Did you work anything out? This just happened, but I will update this later with the things I try.
     
  3. LastOttoman

    LastOttoman Guest

    0
     
    fixed

    SW-Soft was fixed my problem.
    talk with them..
     
  4. RedWolfX

    RedWolfX Guest

    0
     
    Looks like a forced RPM of the psa-* base install worked as well. Save your key before you do it (of course). Just for future reference.
     
  5. bambam4479

    bambam4479 Guest

    0
     
    I have tried the forced RPM install but that has not fixed this problem for me. And I have 1&1 as a host so they won't lift a finger. Any help is greatly appreciated.

    My php.ini points correctly to locales, I've run the command line that also exists in this forum, but neither have fixed me. I'm thinking of uninstalled Plesk and starting fresh.

    What exactly is SW-Soft doing to fix the problem?
     
  6. RedWolfX

    RedWolfX Guest

    0
     
    I believe the problem stems from an incomplete install. I can't be sure of this, but one other host I know of had this problem w/ incomplete install which would explain why a forced install would work.

    Sorry I can't be of more help, but I know when you are desperate it's nice to see a reply...
     
  7. eric.carlson

    eric.carlson Guest

    0
     
    Phew - I'm not alone then!

    I'm getting exactly the same message on the same setup. Can you spell out what a forced RPM install is please - I'd like to try that.
     
  8. worker

    worker Guest

    0
     
    Check this folder:
    /usr/local/psa/admin/htdocs/locales should be owned by root:psaadm

    Check this in the psa database:
    bash-2.05b# mysql -uadmin -p`cat /etc/psa/.psa.shadow` psa -e 'select * from misc where param="def_locale"'
    +------------+-------+
    | param | val |
    +------------+-------+
    | def_locale | en-US |
    +------------+-------+
    bash-2.05b#

    I have had this problem several times, also there is an issue with locale in the help menu somtimes, you can do this to fix it:

    cd /usr/local/psa/admin/htdocs/; ln -s locales/ locale
    cd /usr/local/psa/admin/htdocs/locales/; ln -s en-US/ en
     
  9. bambam4479

    bambam4479 Guest

    0
     
    Thanks Worker, tried all that, restarted plesk, still no dice. Reinstalled the default locale afterwards for kicks and still didn't go.
     
  10. eric.carlson

    eric.carlson Guest

    0
     
    A bit more info

    The owner and db entries were correct already here. I'm still having the problem, but did notice this message when I restarted psa:

    [root@xxx init.d]# ./psa restart
    ===> Reading /etc/psa/psa.conf ...
    PSA is down, perfoming full restart.
    service mysqld does not support chkconfig
    /etc/init.d/mysqld: Too many arguments (first extra is 'start').
    Use --help to get a list of available options

    An old version of the database format was found.\nYou need to upgrade the data format before using PostgreSQL.\nSee (Your System's documentation directory)/postgresql-7.4/README.rpm-dist for more information.
    /usr/local/psa/admin/bin/httpsdctl start: httpd (pid 15642) already running
    Starting Plesk: [ OK ]

    Also, webmin is installed on this server and its working fine (in case thats relevant).
     
  11. eric.carlson

    eric.carlson Guest

    0
     
    Pretty please?

    This has killed the installation dead! Please, can anyone give more clues, its especially annoying seeing as its been reported and then reported as fixed before!!!
     
  12. eric.carlson

    eric.carlson Guest

    0
     
    Pretty pretty pretty please

    With sugar on.

    How many users need to putup with dead servers because of a known problem with a know solution before it gets looked at!

    Was it connected to the Postgres error?
    Do I ned a forced RPM install?
    Hopw do I get officel help - my ISP has bundled plesk in, so I have a key and have paid for it.

    Come on please someone from plesk, its says here you've seen this and fixed it!
     
  13. kevincam

    kevincam Guest

    0
     

    I also had to go into my database change that value to en

    then in the /usr/local/psa/admin/plib/locales folder, cp -rf en-US en .... then go into en and rename all the files ending with en-US to en.......
     
  14. luna

    luna Guest

    0
     
    Hi,

    Could someone help me teach how to change def_locale from command line?
    Thanks in advance.

    Best Regards,
     
Loading...