1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Plesk Cannot delete domain "Unable to set quota"

Discussion in 'Plesk for Linux - 8.x and Older' started by gee_fin, Nov 14, 2006.

  1. gee_fin

    gee_fin Guest

    0
     
    I've got this issue on two domains now, when trying to delete the domain through the control panel Plesk returns with -

    Code:
    ERROR: PleskFatalException  	
    Unable to remove hosting: Unable to delete system user: SysUser->systemRemove() failed: usermng failed: usermng: Unable to set quota for user 'xyzxyz'
    
    0: /usr/local/psa/admin/plib/class.PhDomain.php:228
        PhDomain->reset(integer '0', boolean true, boolean false)
    1: /usr/local/psa/admin/plib/class.BsDomain.php:289
        BsDomain->reset(integer '0')
    2: /usr/local/psa/admin/plib/class.BsDomain.php:283
        BsDomain->delete(integer '0')
    3: /usr/local/psa/admin/plib/class.BsDomain.php:524
        mdeleteDomains(array)
    4: /usr/local/psa/admin/plib/class.Manager.php:351
        Manager->removeDomains(array)
    5: /usr/local/psa/admin/htdocs/domains/domains.php3:215
    
    And will not free up the xyzxyz domain. Can anyone help shed some light on this? I really need the domain back to setup elsewhere :( Any help whatsoever would be most appreciated :)

    Cheers,
    Graeme.
     
  2. gee_fin

    gee_fin Guest

    0
     
    Can anyone give any guidance/advice with this one? Seems a common occurence now :( It just won't delete domains :( Any help would be really appreciated :confused:
     
  3. Jericon

    Jericon Guest

    0
     
    Try running the following command as root, it tends to fix some issues like the one you're experiencing.

    chmod 4110 /usr/local/psa/admin/sbin/wrapper

    Of course, replace /usr/local/psa with your Plesk Install directory.
     
  4. gee_fin

    gee_fin Guest

    0
     
    Hi Jericon,

    Cheers, I ran it but sadly no change :( Still the same error through the control panel when trying to delete a domain :(

    Really stuck with this one :confused:

    Graeme.
     
  5. gee_fin

    gee_fin Guest

    0
     
    *on hands and knees*

    Can anyone shed any light on this one? Got two domains glaring at me that Plesk won't let me delete :(
     
  6. gnulicence

    gnulicence Guest

    0
     
    Hello

    It is possible that there is segmendation fault with user quota tool.

    I had this problem with Fedora .
    I found a solution with a Suse 9.3
     
  7. gee_fin

    gee_fin Guest

    0
     
    Given up in the end, went into the database and manually removed all corresponding domain entries from the

    psa database - domains table, dns_recs table, dns_zone table and DomainServices tables.

    Not sure if this is the correct way but was at my wits end and on minimal testing it's worked.
     
Loading...