1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice

Plesk Log Errors?

Discussion in 'Plesk for Linux - 8.x and Older' started by danweber, Jul 6, 2005.

  1. danweber

    danweber Guest

    0
     
    Wheneve I add a domain, mailing list or do other changes I get the errors like the one below.

    How can I fix this? Maybe it has something to do with the fact that I removed the default domain after I installed my main hosting domain?

    Thanks a bunch
    Dan


    Unable to query database: Duplicate entry '48-Domain Name' for key 1
    0: /usr/local/psa/admin/plib/class.ActionLog.php:638 psaerror(string "Unable to query database: Duplicate entry '48-Domain Name' for key 1")
    1: /usr/local/psa/admin/plib/class.ActionLog.php:515 logcomponent->submit(integer "48")
    2: /usr/local/psa/admin/plib/class.ActionLog.php:450 actionlog->submitbuffer_()
    3: /usr/local/psa/admin/plib/class.dnsmng.php:223 actionlog->submit()
    4: /usr/local/psa/admin/plib/class.dnsmng.php:75 logdnszoneupdate(string "domain", integer "5", string "spanishcay.org")
    5: /usr/local/psa/admin/plib/cmd_dns.php3:190 dnsmng->updatedomain(integer "5", string "spanishcay.org", boolean false)
    6: /usr/local/psa/admin/plib/class.PhDomain.php:549 create_default_dns(boolean false, integer "5", integer "2", boolean true)
    7: /usr/local/psa/admin/plib/class.BsDomain.php:319 phdomain::update()
    8: /usr/local/psa/admin/htdocs/domains/create_domain.php:133 bsdomain->update()
     
  2. serve-you.net

    serve-you.net Guest

    0
     
    Did you manually delete the domain, or do it from within plesk? It seems that your database has some incorrect data in it.
     
  3. danweber

    danweber Guest

    0
     
    The server came set with a "default-domain" and I then added my main hosting domain and after that I deleted the "default-domain", all from within Plesk control panel.

    I looked at the database tables and I have noticed that the record IDs plesk was trying to use where already in use. So I deleted all log entries from the control panel but it did not delete them from the database, not all of them anyways. I suspect the entries did not get deleted because I changed the default domain before I did the delete and these entries probably where associated with the old default domain and therefore not being deleted. I probably could have avoided the problem by deleting the records before I removed the default domain.

    Anyhow, the index has been way past the duplicate ids now and it all seems to be working fine now.

    Dan
     
Loading...