1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

pleskrestore - Single domain restore fails - Client does not exist but is expected to

Discussion in 'Plesk for Linux - 8.x and Older' started by incredible, Nov 27, 2006.

  1. incredible

    incredible Guest

    0
     
    Plesk version: psa v8.0.1_build80061018.17 os_CentOS 3.6

    Operating system: Linux 2.4.21-37.ELsmp

    Whenever we try to do a single domain restore from a Plesk generated full-backup file we get the error: "Client x does not exist but is expected to" where x equals the domain's client username.

    The backup and the restore processes are all done on the same server and the client’s account under which the domain is to be restored exists and it is working perfectly, but each and every time we get the error above.

    Here are the commands issued:
    1) pleskrestore --create-map full_server_backup_file –map map_file -verbose

    2) pleskrestore --validate-map map_file -verbose
    Map validates OK.

    3) pleskrestore --restore full_server_backup_file -level domains -filter list:domain.com -map map_file –verbose
    Client x does not exist but is expected to

    Anyone here having the same problem as we do? Any solutions or workarounds maybe?

    Thanks for your time.
     
  2. Limedrink

    Limedrink Guest

    0
     
    Has the domain recently been changed over to a new client owner?

    The only thing I can think of is that it's trying to restore the domain into the old client name that was used before the full backup was made, which no longer exists.
     
  3. DCNet_James

    DCNet_James Guest

    0
     
    Edit the map file, and change the client name.

    You also need to make sure the domain is already created in PSA preferably under the same client name, if not, edit the map file as stated above with whatever client username it's now under.

    If you've changed anything else like the IP of the domain, you will need to take steps to correct those as well.

    I just ran through this recently when moving a single domain from a full backup from one server to another.

    If you have any questions let me know...

    See the following:
    http://download1.swsoft.com/Plesk/Plesk8.0/Doc/plesk-8-backup-restore-users-guide/18921.htm
     
  4. incredible

    incredible Guest

    0
     
    First of all thanks to all for your replies.
    The restore process of the domain is being carried out at the same server under the same client, which already exists.
    We tried restoring the domain while the old one still existed and we also tried deleting the old one to do a clean restore. But still the same message. The IP and pretty much everything else (databases, administrators, web users, mail accounts etc) remains the same. The map file is correct as it works well for all other types of restore levels (all, clients).

    We are really running short on ideas. Maybe any log files we could dig into?

    Thanks again!
     
  5. Thoms

    Thoms Guest

    0
     
    Hi,

    I have the same problem. Even a backup of the empty domain do not restore. Changed clients name and edited map file... Nothing. Debug-output says all things cool.

    But: The debug was in My locale. In this case german. Try to switch all languages back to default en_us/english. After this it seems to work okay! It looks like a problem with parsing the output of the client-infos.

    Greetings
    Thoms
     
Loading...