1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

preupgrade_checker: WARNING: IP address registered in Plesk is invalid or broken

Discussion in 'Plesk 11.x for Linux' started by Ali N., Jul 3, 2012.

  1. Ali N.

    Ali N. Guest

    0
     
    Hello,

    I have installed Plesk Panel 10.4.4 on Debian squeeze 64bit. Now I want to upgrade this panel to Plesk 11, but when I run the installer in preupgrade check step I get following warning:


    Components validation detected at least one important issue:
    Parallels Panel pre-upgrade check...
    PHP Warning: in_array() expects parameter 2 to be array, null given in /root/parallels/PSA_11.0.9/examiners/panel_preupgrade_checker.php on line 1588
    WARNING: IP address registered in Plesk is invalid or broken: 85.xxx.xxx.xxx

    Proceeding with installation or upgrade without resolving the issues
    that were found can corrupt your data.

    IP is masked. I found this topic http://forum.parallels.com/showthread.php?t=257007 and fix is easy, but looks like plesk does not have fixed this on their servers. My manual changes to that file are removed if i rerun installer script because installer download the file every time from plesk servers.

    Any ideas how to proceed and will this preupgrade script have impact if i continue with upgrade without resolving this issue?

    All ideas are welcome.

    Thank you in advance.

    Best regards,
    Ali
     
  2. Nikolay.

    Nikolay. Silver Pleskian

    17
    35%
    Joined:
    Jul 1, 2012
    Messages:
    844
    Likes Received:
    2
    Preupgrade checker script is designed to detect possible errors in your Plesk installation before upgrade. It does not (or at least should not) modify anything on your system. As any software, this script may contain bugs. Therefore ignoring preupgrade checker warnings is OK if you are confident that you don't really have any problem.
     
  3. Ali N.

    Ali N. Guest

    0
     
    Hi Nikolay,

    Thank you for your informative reply.

    I was worry only if this script will have any impact to plesk upgrade procedure if it pass some data to next steps during upgrade. This is why I decided to ask here before to take any actions :)

    Especially for this warning I'm sure IP is set correctly and as i have also good working 10.4.4 installation :)

    Thank you again and best regards,
    Ali
     
Loading...