1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Probem after upgrading to Plesk 8.4.0

Discussion in 'Plesk for Linux - 8.x and Older' started by fpak0055, May 3, 2008.

  1. fpak0055

    fpak0055 Guest

    0
     
    I have update my Plesk 8.3.0 to 8.4.0 via Plesk Updater: now all my sites show default pagaes of Plesk and my emails doesn't work.

    My VPS [Rhel3] doesn't run properly

    "Service is not available now, probably your Plesk is misconfigured.
    Contact Your provider for details.

    Internal Plesk error occurred: Components::componentUpdate() failed: Unable to exec utility packagemng: packagemng: Unable to connect to Plesk Database: Client does not support authentication protocol requested by server; consider upgrading MySQL client packagemng: Unable to connect to the mysql database
    "

    I have tryed to set OLD_PASSWORD in /etc/my.cnf and

    mysql> UPDATE mysql.user SET Password=OLD_PASSWORD('*******')
    -> WHERE Host ='localhost' AND User ='root' ;

    but nothing changed, except the error message when i TRY to use my Plesk Control Panel

    "Service is not available now, probably your Plesk is misconfigured.
    Contact Your provider for details.

    Internal Plesk error occurred: Unable to connect to database: saved admin password is incorrect
    ."

    How Can i resolve ?

    I have mysql4 installed on my VPS: i have to update to mysql5 ? how ?

    Thank you all!
     
  2. Cranky

    Cranky Guest

    0
     
    Exactly what version of MySQL are you running?
     
  3. fpak0055

    fpak0055 Guest

    0
     
    [root@vps262 root]# yum info mysql
    Gathering header information file(s) from server(s)
    Server: Atomic Rocket Turtle - 3ES - Atomic PSA-Compatible RPMS
    Server: Atomic Rocket Turtle - 3ES - Atomic PSA App Vault RPMS
    Server: Atomic Rocket Turtle - 3ES - SW-Soft PSA 8.3 RPMS
    Finding updated packages
    Downloading needed headers
    Looking in Available Packages:

    Looking in Installed Packages:
    Name : mysql
    Arch : i386
    Version: 4.1.21
    Release: 2.rhel3.art

    Size : 7.15 MB
    Group : Applications/Databases
    Repo : Locally Installed
    Summary: MySQL client programs and shared libraries.
    Description:
    MySQL is a multi-user, multi-threaded SQL database server. MySQL is a
    client/server implementation consisting of a server daemon (mysqld)
    and many different client programs and libraries. This package
    contains the MySQL client programs, the client shared libraries, and
    generic MySQL files.
     
  4. fpak0055

    fpak0055 Guest

    0
     
    ok, i have solved my problems with Plesk Control Panel following this thread

    http://kb.odin.com/en/346

    and Plesk Control Panel works fine now, but now, ALL MY SITES shows DEFAULT PLESK PAGES and not the right index.html page and all emails accounts of my domains hosted on my VPS doesn't work (login are incorrect)


    how can i fix this ?
     
  5. Cranky

    Cranky Guest

    0
     
    Try running:
    /usr/local/psa/admin/bin/websrvmng -av

    It will repair some Apache configuration files and restart Apache.
     
  6. fpak0055

    fpak0055 Guest

    0
     
    [root@vps262 vhosts]# /usr/local/psa/admin/bin/websrvmng -av
    [root@vps262 vhosts]#


    ok, and all my websites works!!!! you did the trick! :D

    but emails accounts doesn't work: there is a similar command for emails accounts ?
     
  7. Cranky

    Cranky Guest

    0
     
    Yes, /usr/local/psa/admin/bin/mchk -v
     
  8. alex07

    alex07 Guest

    0
     
    I got this failure in Horde and Web after upgrading

    Database Error: Unable to connect to the database:The MySQL adapter "mysql" is not available.

    Php5 seems to be dead now. Any suggestions?
     
  9. alex07

    alex07 Guest

    0
     
    KeyUpdateChecker::doCheck: no components for check key update
    skip package 'drweb-base-4.33-5psa.i386' from component drweb - there is same or newer version of this package is installed (in system drweb-base-4.33-5psa.i386)
    skip package 'drweb-daemon-4.33-5psa.i386' from component drweb - there is same or newer version of this package is installed (in system drweb-daemon-4.33-5psa.i386)
    skip package 'drweb-updater-4.33-4psa.i386' from component drweb - there is same or newer version of this package is installed (in system drweb-updater-4.33-4psa.i386)
    Checking whether the package dependencies are resolved.
    Check package set before installation
    Installing packages
    Reading package lists...
    Building dependency tree...
    The following extra packages will be installed:
    drweb-qmail libpam-plesk log4cpp-plesk php5-cli php5-curl php5-gd php5-mysql
    php5-xsl plesk-skins psa psa-api psa-api-rpc psa-awstats-configurator
    psa-backup-manager psa-backup-manager-vz psa-courier-imap
    psa-courier-imap-add psa-firewall psa-ftputil psa-horde psa-imp psa-ingo
    psa-kronolith psa-locale-base-en-us psa-locale-de-de
    psa-manual-custom-skin-guide psa-migration-manager psa-mimp psa-mnemo
    psa-passwd psa-proftpd psa-proftpd-inetd psa-pylibplesk psa-qmail
    psa-qmail-rblsmtpd psa-rubyrails-configurator psa-spamassassin psa-turba
    psa-updates psa-vpn sshterm
    The following packages will be REMOVED:
    libapache2-mod-php5* php5-imap* php5-mysqli* psa-hotfix3* psa-hotfix4*
    psa-php5-configurator*
    The following NEW packages will be installed:
    libapache2-mod-php4 libdb4.4 php5-xsl plesk-skins psa-pear
    psa-php4-configurator
    The following packages will be upgraded:
    drweb-qmail libpam-plesk log4cpp-plesk php5-cli php5-common php5-curl
    php5-gd php5-mysql psa psa-api psa-api-rpc psa-awstats-configurator
    psa-backup-manager psa-backup-manager-vz psa-courier-imap
    psa-courier-imap-add psa-fileserver psa-firewall psa-ftputil psa-horde
    psa-imp psa-ingo psa-kronolith psa-locale-base-en-us psa-locale-de-de
    psa-manual-custom-skin-guide psa-migration-manager psa-mimp psa-mnemo
    psa-passwd psa-proftpd psa-proftpd-inetd psa-pylibplesk psa-qmail
    psa-qmail-rblsmtpd psa-rubyrails-configurator psa-spamassassin psa-turba
    psa-updates psa-vpn sshterm
    41 upgraded, 6 newly installed, 6 to remove and 9 not upgraded.
    Need to get 82.7MB of archives.
    After unpacking 60.8MB disk space will be freed.
    WARNING: The following packages cannot be authenticated!
    psa-fileserver psa-vpn psa-firewall psa-pylibplesk psa-locale-base-en-us
    libapache2-mod-php4 psa-php4-configurator psa plesk-skins libpam-plesk
    psa-backup-manager psa-api-rpc psa-updates psa-rubyrails-configurator
    psa-manual-custom-skin-guide psa-spamassassin psa-migration-manager psa-api
    log4cpp-plesk psa-ftputil psa-awstats-configurator psa-proftpd
    psa-proftpd-inetd psa-courier-imap psa-qmail psa-courier-imap-add php5-curl
    php5-mysql php5-gd php5-cli php5-common libdb4.4 php5-xsl drweb-qmail
    psa-backup-manager-vz psa-pear psa-horde psa-imp psa-ingo psa-kronolith
    psa-locale-de-de psa-mimp psa-mnemo psa-passwd psa-qmail-rblsmtpd psa-turba
    sshterm
     
  10. Pnia

    Pnia Guest

    0
     
    Cranky, my problem is that mail doesn't works.
    I can´t login in webmail nor outlook express.
    I've used /usr/local/psa/admin/bin/mchk -v and this doesn't works.

    I've tried to update to 8.4 but I can't. The autoupdater email says that multiple packages are skipped because of there is the same or newer and finally says:

    ERROR: Unable to install the requested packages because of package dependency problems.
    Warning! Not all packages were installed.
    Please check if your system services are operable.
    Please, contact product technical support.


    Any idea??
    Web domais works good.

    PD: Sorry for my english, i'm spanish.
     
  11. fpak0055

    fpak0055 Guest

    0
     
    and you did the trick for the second time!!! :D :D

    now my server is fully operative with Plesk 8.4.0!!!

    Thank you cranky! ;)
     
  12. dellison1226

    dellison1226 Guest

    0
     
    Also having problems checking email

    I am also having the exact same problems after an attempt to update from 8.3 to 8.4. I've used /usr/local/psa/admin/bin/mchk -v with no succes. Domains work fine except email. I tried pop and horde webmail.

    The autoupdater email says that multiple packages are skipped because there is the same or newer and finally says:

    ERROR: Unable to install the requested packages because of package dependency problems.
    Warning! Not all packages were installed.

    Any ideas?

    Thank you,
    David
     
Loading...