1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Problem migrating accounts from 2.x to 3.0

Discussion in 'Legacy Sitebuilder Software' started by noimad1, Sep 27, 2006.

  1. noimad1

    noimad1 Guest

    0
     
    Hi,

    I've tried running:

    sb_config --migrate_all

    However, I get these errors:

    Migration process started:
    [2006-09-27T21:00:43-05:00 - #1 - info] Site data migration for site 'dave' was started.
    [2006-09-27T21:00:43-05:00 - #2 - warning] Cannot create directory /usr/local/sitebuilder/htdocs/sites/1f/1fe42748bf733907a056c81e6f5b2058 for site.
    PHP Notice: Undefined index: eug-21 in /usr/local/sitebuilder/include/SB/Migration/Site.php on line 216
    [2006-09-27T21:00:43-05:00 - #3 - info] Created dsn - FTP:sprinkler@apple1:::httpdocs.
    [2006-09-27T21:00:43-05:00 - #1 - error] Exception : SQLSTATE[23000]: Integrity constraint violation: 1048 Column 'template_id' cannot be null; file: /usr/local/sitebuilder/include/Zend/Zend/Db/Adapter/Abstract.php; line: 156; code: 23000
    PHP Warning: fwrite(): supplied argument is not a valid stream resource in /usr/local/sitebuilder/include/SB/Migration.php on line 30

    Anyone else have trouble with the conversions after upgrade?
     
  2. noimad1

    noimad1 Guest

    0
     
    Ok, so if no one has had this problem, does anyone at least know if there is a way to manually migrate the sites?

    I really need to get my users sites back up and running....

    This has been the worst upgrade I've ever had to perform, and it's going on 3 days now....
     
  3. tnats@

    tnats@ Guest

    0
     
    Any luck? I don't have any users yet so I just dropped 2x and installed 3 from scratch.
     
  4. noimad1

    noimad1 Guest

    0
     
    nope, was never able to get the sites converted.

    Luckily I only actually have about 5 domains. I just went ahead and re-created them. Well 2 out of the 5 so far. It is a pain in the butt, but it is the only thing I could do to get them back up and running.

    I've only had 2 out of the 5 want to edit their sites so far. So the other 3 I am converting when I get time....

    What a pain. This has been the most ridiculous upgrade I've ever gone through...
     
Loading...