1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

problems after upgrading from 7.1.6 to 7.5.1

Discussion in 'Plesk for Linux - 8.x and Older' started by Shehabi, Jan 1, 2005.

  1. Shehabi

    Shehabi Guest

    0
     
    after upgrading my Server to please 7.5.1 i get weird interface.
    I think something wrong with the language, I tried to reinstall the language rpm the same result, reinstall the whole thing, same result.
    ok I checked the database ..
    I got 2 tables in use (( Modules ,, PMM ))

    all the inteface look like the attached file

    also when I click on modules it wont work as I mentioned that the table isn't working .. so I get the following error
    ERROR
    Unable to query: Can't find file: 'Modules.MYI' (errno: 2)

    --------------------------------------------------------------------------------

    0: /usr/local/psa/admin/plib/common_func.php3:2 psaerror(string "Unable to query: Can't find file: 'Modules.MYI' (errno: 2)")
    1: /usr/local/psa/admin/plib/modules/ModuleMaker.php:2 db_query(string "SELECT id, name, packname, display_name, version, release, description, icon FROM Modules ORDER BY name;")
    2: /usr/local/psa/admin/htdocs/modules/modules.php:2 getmodules()

    so I checked the file in /var/lib/mysql/psa
    oh .. the file isn't there only the .frm file exsist

    can anyone help solving this?
    maybe if I can get the table structures and recreate them.
    is it what is causing the language pharse not to work?

    Thanks
     
  2. Shehabi

    Shehabi Guest

    0
     
    Anyone !!!
     
  3. anton_latvia

    anton_latvia Guest

    0
     
    Well... Of course you can recreate that particular table, but probably other tables could be corrupted. First of all try to fix them using MySQL tools.

    I can't really help you, as I am still running Plesk 7.1.5, because of few errors - I am waiting for the 7.5.2. And I don't have such (Modules) table in psa database. :(
     
  4. Shehabi

    Shehabi Guest

    0
     
    anton_latvia thanks for your reply.

    can anyone get the table structure of PMM and Modules ??

    thanks
     
  5. Shehabi

    Shehabi Guest

    0
     
    Anyone can give me the structure of the PSA database?
     
  6. NightStorm

    NightStorm Guest

    0
     
    Bump because I am being told that the Modules database does not exist.
    I have also searched my server, and there is no database table by the name Modules.MYI.
    Does anyone have the SQL code I can enter in to create this table?
     
  7. gigcity

    gigcity Guest

    0
     
    I'm getting a similar error - except it occurs when trying to add a site, or user or start a service... Anyone know where to find the table structure for exp_event?



    Unable to query: Table 'psa.exp_event' doesn't exist

    --------------------------------------------------------------------------------

    0: /usr/local/psa/admin/plib/common_func.php3:177 psaerror(string "Unable to query: Table 'psa.exp_event' doesn't exist")
    1: /usr/local/psa/admin/plib/api-rpc/loger.php:56 db_query(string "SELECT COUNT(*) FROM exp_event WHERE event_type = 'terminated' AND obj_class = 'service' AND source = 'plesk'")
    2: /usr/local/psa/admin/plib/class.ActionLog.php:443 log_event(string "service", string "dns", string "started")
    3: /usr/local/psa/admin/plib/class.ServiceControl.php:449 actionlog->submit()
    4: /usr/local/psa/admin/htdocs/server/restart_services.php:18 servicecontrol->action()
     
  8. voided

    voided Guest

    0
     
    i started to get the same message when i click on the server modules... the .myi and .myd seem to just have disappeared :(

    ps. i did upgrade mysql to 4.0.x (arts)

    psa v7.5.2
     
  9. lvalics

    lvalics Silver Pleskian Plesk Guru

    36
    43%
    Joined:
    Jun 20, 2003
    Messages:
    965
    Likes Received:
    32
    Location:
    Romania
    any solution on this?
     
Loading...