1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Removing a domain.

Discussion in 'Plesk for Linux - 8.x and Older' started by thinkbsd, May 16, 2006.

  1. thinkbsd

    thinkbsd Guest

    0
     
    I dont know what the problem is, I went to go and remove this domain and I received this error.


    ERROR: PleskException
    Table::select() failed: no such row in the table

    0: /usr/local/psa/admin/plib/dns/DNSZone.php:52
    DNSZone->DNSZone(string '17')
    1: /usr/local/psa/admin/plib/common_func.php3:2555
    objectMaker(string 'DNSZone', string '17')
    2: /usr/local/psa/admin/plib/dns/DNSManager.php:39
    DNSManager::getDNSZone(string '17')
    3: /usr/local/psa/admin/plib/class.Domain.php:644
    Domain->getDNSZone()
    4: /usr/local/psa/admin/plib/class.PhDomain.php:207
    PhDomain->reset(integer '0', boolean true, boolean false)
    5: /usr/local/psa/admin/plib/class.BsDomain.php:289
    BsDomain->reset(integer '0')
    6: /usr/local/psa/admin/plib/class.BsDomain.php:283
    BsDomain->delete(integer '0')
    7: /usr/local/psa/admin/plib/class.BsDomain.php:524
    mdeleteDomains(array)
    8: /usr/local/psa/admin/plib/class.Manager.php:351
    Manager->removeDomains(array)
    9: /usr/local/psa/admin/htdocs/domains/domains.php3:215

    Anyone?

    FreeBSD 5.4
    Plesk v8
     
  2. ciberjohn

    ciberjohn Guest

    0
     
    I have the same exact problem.....in fedora 4, plesk 8
     
  3. thinkbsd

    thinkbsd Guest

    0
     
    fixed it by myself no thanks to support!

    Okay after a week for waiting on any replys, i went ahead and attempted to fix it for myself.

    The FIX: Install a mysql client such as phpmyadmin or if you are familiar with mysql then you have to manually login to mysql via root account and manually delete the domain yourself. BACKUP EVERYTHING before you do this, for safety measures of course..

    After I manually deleted the domain in mysql, i was able to login to plesk and the domain was gone! Plus, just to check, i readded the domain and redeleted it through plesk.. Everything works smooth..

    Its almost like you're your own support. Thanks to me!
     
  4. ciberjohn

    ciberjohn Guest

    0
     
    belive it or not, that was the way I was planning to do. Could you please bee so king to tell where and what you deleted in de psa db ? thanks in advance.
     
  5. ciberjohn

    ciberjohn Guest

    0
     
    well..didn'd erase totally, only erased the domain name from the table. Solved.
     
  6. willyk@

    willyk@ Guest

    0
     
    Hi I have the same problem,

    any chance you could tell me what i have to delete via shell.

    Unfortunately i dont have PHPmyadmin installed as of yet and i need this domain deleted.

    Thanks
     
  7. ciberjohn

    ciberjohn Guest

    0
     
    if you are talking about plesk 8, you have by defautl phpMyAdmin...just go to server, databeses/databases server then, before you choose any db existing, just click on Db WebAdmin...there you go.
     
  8. willyk@

    willyk@ Guest

    0
     
    cant see phpmyadmin

    When i click DB Webadmin the page just refreshes and does nothing.

    I think this is a problem with the MYSQL root password that i have been unsuccesfully trying to change. I have seen probably every possible post on this matter and followed step by step but still cant login to mysql as root
     
  9. cpinto

    cpinto Guest

    0
     
    My Solution


    INSERT INTO `dns_zone` VALUES (17, 'namedomain.com', 'namedomain.com', 0, 'soporte@caminoweb.com', 'master', 86400, 86400, 10800, 3600, 3600, 3600, 604800, 86400, 10800, 3600);

    17 --> id domain
    namedomain.com --> name of domain
    Obtain values of table dns_zone.


    domain.sh -r namedomain.com
     
  10. renegadeavenger

    renegadeavenger Guest

    0
     
    yeah, that is the only way you can remove a domain if it doesn't removed correctly. You have to manually remove from database and then delete all other traces of the domain.
     
  11. DCNet_James

    DCNet_James Guest

    0
     
    For the guy who asked where the phpmyadmin was, heres a link you can use once you're logged into your PSA server, of course replace server.domain.com with the FQDN of your server...

    https://server.domain.com:8443/serv...admin&db_server_id=1&previous_page=db_servers

    Select your psa database.
    Goto the domains table, run the sql query:
    SELECT * FROM `domains` WHERE 1

    You'll be presented a list of domains, delete the one you want. You'll also have to do some cleanup manually, but should fix your problem, not saying this is the best way to do it but it works. On another note, I'm running FreeBSD and have never seen this issue.


    I know theres a way to do it from the CLI, but I'm not sure what it is.

    Someone also asked for the root user of the mysql server, just use the credentials for your admin user.
     
  12. alizabet_nguyen

    alizabet_nguyen New Pleskian

    6
     
    Joined:
    Apr 15, 2014
    Messages:
    3
    Likes Received:
    0
    Hi I have the same problem,

    any chance you could tell me what i have to delete via shell.

    Unfortunately i dont have PHPmyadmin installed as of yet and i need this domain deleted.

    Thanks
     
Loading...