• Debian 11 has reached its end-of-life (vendor EOL date - August 31, 2026). Plesk Obsidian 18.0.81 is the last release to support it.
    If you are running Plesk Obsidian on Debian 11, we recommend you upgrade those servers to Debian 12 using our dist-upgrade tool.
  • We plan to deprecate and remove the support for XML RPC protocol versions earlier than 1.6.9.1 in Plesk Obsidian 18.0.82. We strongly recommend that you update all existing integrations using earlier versions of the XML RPC protocol to comply with the version 1.6.9.1 specification.

Session.save_path - Default path changed, permission denied error

Xavier12

Regular Pleskian
Hey guys,

Not sure what is going on with Plesk.. I've modified and saved a specific service plan with the session.save_path to have a location by default to be /tmp/ and for some reason it isn't changing all customers accounts with the modified settings of the location to be /tmp/. In order to resolve the issue, I'd have to manually change the "default" option on each websites php settings session.save_path to /tmp/ instead of Plesk syncing the correct settings based on the modification. Because of so, I am receiving the following error below on a customers website below:

Warning: Unknown: open(/var/lib/php/session/sess_f9bffgv0ddrjo9geb6frhut5d7, O_RDWR) failed: Permission denied (13) in Unknown on line 0 Warning: Unknown: Failed to write session data (files). Please verify that the current setting of session.save_path is correct (/var/lib/php/session) in Unknown on line 0

After making changes, I've tried the following in command line:

service php-fpm restart
service httpd restart
service psa restart

None which have resolved the issue.

Please advise, thnx!
 
Back
Top