1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Sitebuilder behind firewall

Discussion in 'Sitebuilder 4.0 for Windows' started by dmiller@, Sep 19, 2006.

  1. dmiller@

    dmiller@ Guest

    0
     
    I have a SiteBuilder 3.2 installation behind a firewall with multiple ips. I can browse to the wizard externally thru any of the ips /subdomains with no problem but when I try and preview a site in the wizard it tries to resolve it to a local ip, behind the firewall, which fails. It always goes to the first internal ip. How would I correct this to resolve to the external ips/domains?
     
  2. GlobalServe

    GlobalServe Basic Pleskian

    24
    23%
    Joined:
    Aug 15, 2005
    Messages:
    89
    Likes Received:
    0
    Same problem here...
     
  3. MCLives

    MCLives Guest

    0
     
    Any Fix for this yet?

    I have the same issue. Anyone find a fix?
     
  4. dmiller@

    dmiller@ Guest

    0
     
    Solution

    I have gotten this to work. At least to most extent.

    First I have multiple IP's behind the firewall. All incoming requests to the web server seem to default to the first one "<firstIP>".

    Here is what I did:

    1. I set up a domain for our hosting company "<maindomain>" using that IP address "<firstIP>". This is the Sitebuilder url we use for trial sites and also give to our clients to administer thier sites - sitebuilder.<maindomain>.com

    2. Added an entry in the host file:
    "C:\WINDOWS\system32\drivers\etc\hosts"

    <firstIP> sitebuilder.<maindomain>.com

    3. Added identity in IIS for the main SiteBuilder web site(not the Sitebulder(default) site ).
    IP = <firstIP>, port = 80, hostheader = sitebuilder.<maindomain>.com

    4. Modified main sitebuilder web.config "C:\Program Files\SiteBuilder\Web\web.config"

    From:

    <!-- <add key="PreviewHostUrl" value="tcp://localhost:1455/WebApplicationHost.rem"/> -->

    To:

    <add key="PreviewHostUrl" value="tcp://sitebuilder.<maindomain>.com:1455/WebApplicationHost.rem"/>

    5. In SiteBuilder "Publishing Settings" I use FTP and the local, behind the firewall, ip address for the domain of the client site.

    This is working for me. I would be very interested if anyone has found any other solutions or has anything to add.

    Also I am now using this solution with SiteBuilder 4.0.0
     
  5. Dmitry Frantsev

    Dmitry Frantsev Golden Pleskian

    28
    57%
    Joined:
    Sep 19, 2005
    Messages:
    1,911
    Likes Received:
    0
  6. Dmitry Frantsev

    Dmitry Frantsev Golden Pleskian

    28
    57%
    Joined:
    Sep 19, 2005
    Messages:
    1,911
    Likes Received:
    0
    I have also moves this thread to appropriate place on this forum: section Sitebuilder for Windows > Sitebuilder 4.0 for Windows > Sitebuilder 4.0 for Windows Troubleshooting Issues
     
Loading...