1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Switch Off Mail Service to solve Google Apps email problem

Discussion in 'Plesk 10.x for Linux Issues, Fixes, How-To' started by Mike1, Feb 3, 2011.

  1. Mike1

    Mike1 Guest

    0
     
    I encountered this problem initially a year ago when setting up Google Mail for my domain sturents.com. My registrar is 123-Reg, so when I set up GMail I set the MX records on the 123-Reg control panel. Most email servers on the internet could email @sturents.com without issue, however when emailing from my own domain (1webservices.co.uk) hosted on the same server as sturents.com I would get "5.5.0 no mailbox by that name" reports. I eventually solved the issue by adding the same MX records into the Plesk 9.x DNS settings for sturents.com AND switching off the mail service for that domain.

    This was the case for every subsequent Google Apps domain when being emailed from an SMTP server running on the same box - my assumption is that the initial lookup for the domain by the SMTP server finds that the mail server is on the same box (before it hits MX) and so it looks for a local mail server - if it finds one it tries to send the mail locally, but the address doesn't exist so it fails. By switching off email for the domain on Plesk the SMTP server doesn't find a local mail server, looks at the MX records and sends the message to Google as intended.

    I have recently moved to a new server which runs Parallels Small Business 10.x. I have added all the correct DNS records and am encountering the same problem again (5.5.1 Recipient address rejected: User unknown in virtual mailbox table), but this time I am unable to find how to disable email for a domain. On 9.x I went to "Domain -> Sturents.com -> Email -> Switch off" but now the Email tab lists addresses for all domains, and there are no switch off options. If I can't achieve this through the panel can anyone tell me how to carry out the process in the shell, as this is critical for emailing clients who have switched to using Google Apps hosted on my server.

    Thanks in advance for any help.
     
  2. Mike1

    Mike1 Guest

    0
     
    Seems I should probably have posted this in the Small Business forum, somehow I missed that when looking through the forums. Any chance of a moderator shifting this thread so that it gets some attention? Thanks.
     
  3. Mike1

    Mike1 Guest

    0
     
    I have now solved this problem, simply enter a shell and use the following command:
    Code:
    /usr/local/psa/bin/domain -u DOMAINNAME -mail_service false
    Where DOMAINNAME is your domain. This should solve all issues sending between domains on the same server when the recipient is using Google Apps. Others have reported that the solution does not work, but they may not have set up the MX records inside Plesk as well as outside with their domain registrar.
     
  4. markross

    markross Guest

    0
     
    An update to this - I spent quite a long time trying to figure out why this wasn't working. I had tried everything mike1 suggested. Then I remembered I switched the MTA from qmail to postfix a while back. Switching back to qmail and mike1's solution works.
     
  5. markross

    markross Guest

    0
     
  6. Surferride

    Surferride Guest

    0
     
    Hello, I have this exact same problem, but on a Windows Plesk. I am unable to disable the mail service only for a certain domain. I´ve hitted the "switch off mail service checkbox" but it disabled email for all the domains within that account which I dont want. Is this a Parallels problem that should get a quick fix ASAP? Thanks a lot!
     
  7. IgorG

    IgorG Forums Analyst Staff Member

    49
    24%
    Joined:
    Oct 27, 2009
    Messages:
    24,576
    Likes Received:
    1,244
    Location:
    Novosibirsk, Russia
    Did you try solution http://forum.parallels.com/showpost.php?p=437687&postcount=3 for Windows domain.exe utility? BTW, please, continue discuss your issue in Plesk for Windows forum section.
     
  8. Toe Knee

    Toe Knee New Pleskian

    6
     
    Joined:
    Jul 11, 2013
    Messages:
    1
    Likes Received:
    0
    I don't even know if you guys still check this thread, but THANK YOU SO MUCH! You guys helped me solve this pain of a problem that we've been having. Turning off the mail service was the solution for me.
     
  9. Nibbels_

    Nibbels_ New Pleskian

    6
     
    Joined:
    Dec 22, 2013
    Messages:
    3
    Likes Received:
    0
    Hello and thanks for your help on my path to solve the same problem as you all.

    What are the facts?

    I am using an webserver with plesk. I have my domains on a standard-webspace because i want to be able to switch my server without having the domains and emails touched.
    Mails shall run within the strato-system. Website should run with databases on this server.

    Now whenever I send Mails from my server via PHP towards my own mailname@mydomain.de this fails and I get the same problem as you have. It wount ever reach the external server because the server thinks that he is in charge to handle this mail, doesnot find any mailbox and the mails get dropped.

    The Server should send the mails out into the internet to reach the strato SMTP. So that the mails will be handled by this external server.

    I did not find an option in Plesk graphical interface.
    First try: I failed. http://forum.parallels.com/showthread.php?261367-Nginx-BAD-GATEWAY&p=713344&viewfull=1#post713344
    Second research after hours of reconstruction: Your thread.
    Third: Look here. ftp://download1.parallels.net/Plesk...inistrator-guide/index.htm?fileName=72346.htm

    Maybe that is the solution others look for. "Using an External SMTP Server for Outgoing Mail (Linux)"

    I will try..

    EDIT: My Third solution wasnt the best solution for me. You can specify a SMTP-Mailserver there but in my case I have no username and passwort for the specified strato mailserver. But in my case I really only need to make my server think that every mailadress is external.

    Installed Qmail.. instead of otherone.
    Mike1's Tipp
    http://prntscr.com/2e40u7 disabled mailservice
    http://prntscr.com/2e420o worked!

    Mike1 you rule! Thanks a thousand times!
     
    Last edited: Dec 26, 2013
Loading...